Engine skip between 1400 and 1600 RPM. Anyone near Chicago? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-01-2010, 05:31 PM Thread Starter
Powerstroke.org Rookie
Join Date: Sep 2009
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Engine skip between 1400 and 1600 RPM. Anyone near Chicago?

Hey everyone, just wondering if anybody is located around Chicago maybe within a couple hours to help do some injector work on my 02 F250. #3 and #8 came up on the contribution test and I really think the Injector O-Rings need to be replaced too. Really want to do the work myself but do not want to mess anything up. I would of course pay by the hour. Truck runs good until it heats up, then the motor makes a sputter/clatter/skip noise between 1400 and 1600 RPMs. No real signs of power loss at all, just driving me nuts. Truck runs good when warmed up, but not in that RPM range. Anyone got any ideas of what else it could be? Let me know if anyone who knows what they are doin wants to make some extra cash. Thanks!
RCS15150 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome