Engine has low rpm miss, skip or shudder - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-22-2010, 04:24 PM
Premium Member
 

Join Date: Sep 2006
Location: New Egypt, NJ
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Engine has low rpm miss, skip or shudder

2003 7.3 L has a miss, skip or shudder from about 1200 rpms to 1500 rpms. To make the shutter go away I just step on the throttle a little more and the skip goes away. When I mash the skinny pedal the truck takes off without a problem. The engine starts up quicly even in the cold weather. The truck idles smoothly and makes plenty of power up top and generally runs well except for this.

The skip is more noticible with the higher HP settings on my TW Chip (extreme). My MODS are in my signature. I don't notice any miss at highway speeds (55mph and up). There is no SES light. I checked the oil rails to make sure they were full of oil and I drove the truck with the ICP sensor disconnected and it didn't make a difference. I'm hearing a louder than normal clackity, clack from the drivers side valve cover. I'm thinking maybe an injector is going bad. Any help would be apreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-26-2013, 04:32 PM
Compression Ignition Addict
 

Join Date: Jun 2011
Location: Eatonton, Lake Oconee
Posts: 563
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Found this old post and curious if the problem was ever solved. Mine is doing the same thing and can't figure out what the problem is. I have had a low torque issue with this shudder for over a year/ 45,000 miles. Any ideas much appreciated.
Reply With Quote Quick reply to this message
  #3  
Old 02-26-2013, 04:46 PM
WNY Biodiesel Co-op
 

Join Date: Mar 2008
Location: Orchard Park New York
Posts: 851
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My problem is a rough idle then smooths out after 1500 RPMS. I'm making a wiring harness that I can put into the VC connector so I can shut off each injector . 1 at a time to try to isolate which one is bad . I know its on the dr side at least.
Reply With Quote Quick reply to this message
  #4  
Old 02-26-2013, 04:54 PM
Premium Member
 

Join Date: Sep 2006
Location: New Egypt, NJ
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was a bad injector. I ran test after test on my A/E software for a year before it finally gave me a couple of failed injectors. I swapped injectors around to figure out which was the problem. Since I had 125K on it and I wanted more power I ended up replacing them all with Rosewood Hybrid injectors and new tuning. problem was solved.
Reply With Quote Quick reply to this message
  #5  
Old 02-26-2013, 05:22 PM
Compression Ignition Addict
 

Join Date: Jun 2011
Location: Eatonton, Lake Oconee
Posts: 563
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the quick response! I am thinking injectors also, but have no sign of that being the exact problem. All buzz and contrubution test at ford dealer was good. I have a scan gauge and no cel, good ipr#'s and icp pressures. Like you good cold starts, just like when new, no smoke except on a hard acceleration. Thinking about full force stage one's and PHP 6 position tune. Thanks for the help!
Reply With Quote Quick reply to this message
  #6  
Old 02-27-2013, 03:32 AM
Premium Member
 

Join Date: Sep 2006
Location: New Egypt, NJ
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You will not be unhappy with that choice. I figured if I was going to spend the $$ on new injectors I might as well go bigger. It is real nice the engine pulls all the way through the rpm range intead of running out of steam at the big end. Just watch your EGT gauge. Plenty of Towing power. I pull 10-12K on a pretty regular basis. 14mpg towing, 16-17 around town summer, 15-16 mpg winter, about 20 mpg on a trip as long as I keep it around 70 ish on the interstates.

You might want to change your injector cups when you pull the injectors. Its relatively simple since you will have everything apart anyway.

Good luck.
Reply With Quote Quick reply to this message
  #7  
Old 02-27-2013, 05:31 PM
Compression Ignition Addict
 

Join Date: Jun 2011
Location: Eatonton, Lake Oconee
Posts: 563
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, for the advise on the cups.
Reply With Quote Quick reply to this message
  #8  
Old 01-21-2014, 04:54 AM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Codum, did you find the problem to be injectors too?

I am having the same problem but I pulled all my injectors and had them bench tested and were said to be good.

Thanks, Michael
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:03 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors