high EGTs, low boost, no power.????? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-20-2010, 07:50 AM Thread Starter
Compression Ignition Addict
 
J. Wheeler's Avatar
 
Join Date: Nov 2008
Location: Comfort, TEXAS
Posts: 312
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy pulled turbo. got question

ok guys i need a second opinion. heres what i got... my dad has an 03 f250 it has an edge chip,afe cold air, MBRP 5in turbo back. it has a stock turbo which i think is goin bad. it has very high egts under any acceleration. just easing the truck from 65 to 70 mph, no power, 1350+ egts, 2psi boost max, lots of black smoke if u mash a little harder but no power. turbo doesnt really spool up at all. I checked all the boots and the intercooler and they checked out good. so im thinging that maybe the turbine losts a few propellers. and that its time for a new turbo. what do yall think? anything i should check before i pull it off? Thanks

Last edited by J. Wheeler; 02-21-2010 at 07:16 PM. Reason: update
J. Wheeler is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 02-20-2010, 08:14 AM
shaking things up

 
jethro's Avatar
 
Join Date: Jan 2009
Location: wexford-Pa
Posts: 3,650
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
you can just take the dp off and look in the exhuast side same on the intake side pull the intake off and inspect that wheel and you can wiggle the wheels to look for shaft play and spin it by hand to see if it spins freely

389.14 HP 726.00 TQ
96 f-350 7.3 with a 5 speed
3 in DP
4 in ex. to 5 in aussies
custom traction bars
TW chip 6 pos
IDM mod
SD IC
HPX
D66
casserly 2's
custom fuel with an AIRDOG 2
910's
*17 TE modded hpop
ebpv gutted
pedestal gutted
gutted ccv elbow
clutch pedal fix

facebook- Graham Maxwell
jethro is offline  
post #3 of 4 Old 02-21-2010, 06:57 PM Thread Starter
Compression Ignition Addict
 
J. Wheeler's Avatar
 
Join Date: Nov 2008
Location: Comfort, TEXAS
Posts: 312
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
turbo pulled. wasnt what i thought

ok i pulled the turbo on my dads 03, it looked fine on the exahaust side. on the compressor side i noticed the wheel was a dark color. the turbo doesnt turn as well as it should. it kinda turns and then has a spot that drags. so i pulled the compressor wheel and found this black smear mark that looks like it rubbed on there by somthing. it looks like exahaust soot. its only on part of the back of the wheel. makes a ring around the back about half way from the center. took it all apart and cleaned it. oiled it up good and now it turns a little easier but it still has a drag spot in it. i thought it was the comp wheel dragging but it even does it with it off the shaft. i think he needs to order a new one or have it rebuilt. any sugestions or ideas. what are yalls thoughts on this Rons Turbo service that iv seen on ebay. Thanks
J. Wheeler is offline  
post #4 of 4 Old 02-21-2010, 07:19 PM Thread Starter
Compression Ignition Addict
 
J. Wheeler's Avatar
 
Join Date: Nov 2008
Location: Comfort, TEXAS
Posts: 312
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anything???
J. Wheeler is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome