oil leak and no power - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-03-2010, 02:17 PM Thread Starter
Serving Our Country!
powerstroke23's Avatar
Join Date: Jan 2008
Location: Norman, Ok
Posts: 153
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oil leak and no power

early 99 cali edition has developed an oil leak that appered to be from the hpop so i replaced the packings about 2 months ago and now i have another leak in the valley and a glow plug code, which i am changeing this weekend, and the truck will randomly lose all power (no rpms with the petal mashed) and die out if i put just a touch of oil in it the problem goes away. The problem happens more fequently on really cold days. Is this just the glow plugs or should look at something else?

powerstroke23 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome