Intermitent loss of power(12v) while driving/idle - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-05-2007, 01:56 AM Thread Starter
Member
 
Ashby's Avatar
 
Join Date: Apr 2006
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Double post please delete

2000 Excursion PSD....Ok here's the deal. My truck has lost power a couple times while driving. The truck was chuggin along and it felt like I had taken my foot off the gas. I looked down and saw the warning lights flash and the gauges jump. Then it was back to normal with everything. Then today I got in my truck to start it. The gauges jumped and then no power to anything. The theft light was flashing but that was it. Would not turn over or power any accesories. After awhile it was back to normal. I have replaced the CPS about 30xxx miles ago. I did not think that this problem was the CPS due to the truck losing power to everything. The truck does not turnover at all like it would when the CPS went out. Any thoughts?

Last edited by Ashby; 04-05-2007 at 02:24 AM.
Ashby is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome