99 7.3 Powerstroke partial misfire - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-17-2010, 10:26 AM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 99 7.3 Powerstroke partial misfire

99 7.3 Powerstroke has a constant but partial misfire, as I am in UK info is really hard to come by. Has had new injectors new injector driver, fuel pump pressure checked, Re ringed, cyllinder heads overhauled, valve in oil filter housing checked. Correct engine oil put in. Mis fire still there! Checked resistance on power control module 1 and 4 running 11-12mv rest range between 20-25mv, more noticable at idle. Not sure if this is normal as I cannot get hold of any data on this vehicle over here. Can anyone help please
Richard1233 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome