01 7.3 trouble...PLEASE HELP ! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-11-2010, 02:56 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
01 7.3 trouble...PLEASE HELP !

I've got a 01 7.3 with 109K miles on it. Several months back I started hearing a knocking sound. It has no low end power whatsoever and runs really rough. Put it on the comp at it said #8 injector was bad. I replaced # 8...Still same problems. A former engineer from ford told me it was most likely the UVC harness. I replaced it....still the same no better. Here are the things Ive noticed:

Low power on takeoff
rough running
Loud knock
CEL comes on when I really get on it at high speed.
Oil in valley on passenger side
Battery light flickers when less than 1200 rpm (not staying on constantly).

Ive been told it may be anything from HPOP, CPS to the Torque converter.

PLEASE HELP !

Any suggestions would be greatly appreciated.
RockinBarM is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-11-2010, 03:09 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Well did you replace the CPS anyway? Easy fix. Might be it. If the OD light flashes it's the trans. Fuel filter clean? Clean fuel? Injectors might be dirty. Bad alternator for the batt light? Maybe HPOP.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jesilvas is offline  
post #3 of 4 Old 01-11-2010, 03:22 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
No OD light...Full service last week. I looked up a new CPS. I know there was a recall but I found 1 for $30 and one for over $100....Which one would I need ? Whats the diff in the 2 ?
RockinBarM is offline  
post #4 of 4 Old 01-13-2010, 07:12 PM
Member
 
Join Date: Dec 2009
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The one I just bought cost close to $30 from Ford.
tex_waco_usmc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome