trouble running - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-05-2010, 07:25 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 1,212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
trouble running

hi, my buddy is going through hell every day getting his truck to run, here's the story.
he plugs it in all the time and the block heater does work. jump in and hit the glow plugs and the wait to start light stays on like the truck hasnt been plugged in, way too long. so start cranking and its hard as hell to start. but after giving the starter a run for it money it will start. thats not really the problem, i can fix that. i can test the GPR and GP. ill put a Western Snow Plow 56131K-1 Relay in it, ive heard that they will last a life time. also replace any GP as needed.

the real headache; after the truck is finally running it runs like hell. sounds like it doesnt have enough fuel/ has a miss or knock. even after the truck has warmed up for 30 min with will still sound like this and the motor will shake just like it sounds. also after warmed up if you try to give it fuel it will kinda knock, like its not getting enough fuel, and die most of the time. trust me i know what a 7.3 sounds like when its not getting any fuel

also when the exhaust break kicks in after a couple min of running it will only stay on for 5-60 seconds.

but when the truck is really really warmed up, like going to the store and back, it ill run like new. bad injector?

thanks a lot for any help
Patrick
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-06-2010, 12:56 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 1,212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anyone????? bump
Reply With Quote Quick reply to this message
  #3  
Old 01-06-2010, 01:00 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Posts: 5,363
Thanks: 1
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
sounds like tired injectors dont like running when cold, how many miles on injectors?
Reply With Quote Quick reply to this message
  #4  
Old 01-06-2010, 02:30 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 1,212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
we the truck has 133K on it. idk if the injectors have been replaced
Reply With Quote Quick reply to this message
  #5  
Old 01-07-2010, 08:38 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Posts: 1,212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bbuummpp...
Reply With Quote Quick reply to this message
  #6  
Old 01-08-2010, 06:37 PM
Member
 

Join Date: Apr 2008
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
how about the icp???? been kinda having the same problem. ses light comes on and truck runs like crap. today i unplugged the icp, started the truck, it ran fine. plugged it back in and all is well, may have been a loose connection somewhere.. dont know if thats your problem or not, but it sounds an awful lot like mine.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors