Turbo Smoked?? Need Help 911 - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-31-2007, 04:20 PM
Fishing Fanatic

 

Join Date: Nov 2006
Location: Where the Navy sends me!
Posts: 400
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo Smoked?? Need Help 911

Here is the deal the best I can explain. Going up through the mountains in TN, I let the EGTs get a little high 1000 for a WHILE, then out of nowhere, BLUE/WHITE smoke everywhere out the exhaust. Let off the gas no more smoke. Pulled over, let truck and turbo cool down, seemed to be OK the rest of the trip except for leaking a little oil now somewhere from top of motor (turbo pedestal???) Then today, I noticed that after I got on the throttle, and let off, a second of so later, POOF a cloud of white/blue smoke out the exhaust. Got home and had wife rev motor, and mixed with black smoke, is some white/blue, and then a few puffs of white/blue after you let off the throttle. So I think, my turbo is shot??!! Whould this seem to be right?? I need some help bad. In Kissimmee right now, but supposed to report back to Key West tomorrow!!! Need you guys bad right now if you could lend me your thoughts.

P.S. How hard is it to rebuild the turbo? Or would it be better to buy one?? Thanks alot guys~!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-31-2007, 05:06 PM
Fishing Fanatic

 

Join Date: Nov 2006
Location: Where the Navy sends me!
Posts: 400
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bump! Guys I need some help bad. Thanks
Reply With Quote Quick reply to this message
  #3  
Old 03-31-2007, 05:14 PM
Serving Our Country!
 

Join Date: Nov 2006
Location: GREAT LAKES,IL
Posts: 636
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
put your hand over the oil filler and see if it builds pressure. might be your rings that went. are you burning any oil. how many miles you have on it
Reply With Quote Quick reply to this message
  #4  
Old 03-31-2007, 05:23 PM
Banned
 

Join Date: Mar 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Do you have a boost gauge..if the turbo is shot then you wont build any boost..........also you can take the inlet hose off and see if the pinwheel is turning.
Reply With Quote Quick reply to this message
  #5  
Old 03-31-2007, 05:26 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2007
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
how does it idle, does it have any weird sounds?

blue smoke is usually injectors leaking oil, white is usually unburnt fuel.

I would guess a bad orings on an injector... but thats totally a keyboard guess.
Reply With Quote Quick reply to this message
  #6  
Old 03-31-2007, 05:38 PM
Serving Our Country!
 

Join Date: Nov 2006
Location: GREAT LAKES,IL
Posts: 636
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
white is also water
Reply With Quote Quick reply to this message
  #7  
Old 03-31-2007, 05:39 PM
Fishing Fanatic

 

Join Date: Nov 2006
Location: Where the Navy sends me!
Posts: 400
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck builds boost like normal. And, no weird noises when I shut it down (like grinding in turbo housing). So I am hoping it is something simple and NOT rings. Turbo seems alot easier to me. Truck really hasn't used alot of oil. Maybe 1/2 a quart on a recent 3500 mile trip. and some of that 1/2 quart is leaking down the motor. Pretty decent leak too. Only seems to leak when I run the truck. Motor has 122K miles on it. Seems really good on power still, and EGT's Tranny, Motor temps all good. Oil Pressure is great SO Where or what do I do now???
Reply With Quote Quick reply to this message
  #8  
Old 03-31-2007, 05:43 PM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Hmm check for any boost leaks.
Reply With Quote Quick reply to this message
  #9  
Old 03-31-2007, 05:45 PM
Serving Our Country!
 

Join Date: Nov 2006
Location: GREAT LAKES,IL
Posts: 636
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
if its building boost then i would not lean torwards teh turbo. did you try the oil filler yet see if its building pressure. check there and see if its trying to blow your hand off it. are you using any coolant.
Reply With Quote Quick reply to this message
  #10  
Old 03-31-2007, 05:50 PM
Fishing Fanatic

 

Join Date: Nov 2006
Location: Where the Navy sends me!
Posts: 400
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Doesn't seem to be low on coolant at all. Exhaust doesn't steam out either. If you are idling, no smoke at all. The only time it smokes, is when you get on the gas and let off of it. After it returns to idle NOTHING. I was thinking maybe the bearings in the turbo were maybe leaking a little, or one of the O rings in there?? Haven't checked for shaft play, and haven't taken off the oil filter to check for pressure yet. Won't I get oil every where if I do that?? Thanks for everything so far guys.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:21 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors