Anybody seen this before? - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-01-2010, 06:26 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Anybody seen this before?

I have an '01 Super Duty pick-up with the 7.3 diesel. It has 106,000 miles since I bought it new, a week after 9/11. It really isn't a daily driver per se. I used to drive it 54 miles daily to work, then drove it less often when diesel pushed close to 5 bucks a gallon in the spring / summer of '08.

Last night, I was driving home when I heard a popping noise from beneath the hood. It sounded like a balloon popping, just as I was pulling out of a subdivision street onto a surface street. The turbocharger immediately began howling, yet it offered no power or torque boost as it normally would. 0-40 MPH took about a minute to reach with my foot on the floor.

The exhaust looked white by flashlight when I completed the 7-8 mile trip home. The engine idled like it normally did - no knocking sounds at any time. Oil pressure and engine temp gauges were normal, as was the oil level after I shut off my engine. The last oil change was done in July (roughly 2000 miles ago).

I looked at the truck during daylight hours today. I noticed an oil leak OUT OF THE FRONT SEAM OF MY MUFFLER!! At first I thought just the turbo was fried last night, but now I fear that a head gasket is gone as well.

Additionally, the dealer changed a cam positioning sensor several months ago. The check engine light came on shortly afterward. Low end torque hasn't been as good since the trip to the dealer. Towing a trailer at highway speeds about a month ago was smoother than low speed driving with no load.

Has anybody else seen this type of power loss coupled with the turbo being basically useless? Thanx!
Born-in-the-USA is offline  
post #2 of 5 Old 01-01-2010, 06:41 PM
Compression Ignition Addict
 
panheadjay's Avatar
 
Join Date: Jun 2009
Location: Terre Haute IN
Posts: 297
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
check intake boots and intercooler boots see if one is busted.
panheadjay is offline  
post #3 of 5 Old 01-23-2010, 12:42 PM
Powerstroke.org Rookie
 
Join Date: Sep 2009
Location: just outside of houston, texas
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
you blow your turbo
mustangvirgil is offline  
post #4 of 5 Old 01-23-2010, 12:58 PM
Compression Ignition Addict
 
Austinj427's Avatar
 
Join Date: Nov 2008
Location: Castle Rock, Colorado
Posts: 1,538
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Is there play in the turbo? You can rebuild them if it is side to side play, I think the kit is like 60 bucks from beans. Back and forth, well I'm sorry you'll need a new one.

I DOUBT you blew a head gasket. Did the degas bottle over flow?

Did you check your oil? Truck could be drinking that up through the turbo.
Austinj427 is offline  
post #5 of 5 Old 01-28-2010, 06:47 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yup, the oil level was low the next day. I lost a couple qts. thru the exhaust, and it blew white smoke on the short drive to the dealer. The turbo had to be replaced.
Born-in-the-USA is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome