Fuel Pump Problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-17-2009, 04:35 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Location: Ringtown, PA
Posts: 618
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Fuel Pump Problems

I just swapped the body on a rolled over 2001 lariat. EVERYTHING has been changed, from the transmission all the way through the wiring harnesses. Before we swapped the body the truck ran pretty good with a little smoke that was probably just from the oil residue in the intake from being rolled over.
Since we changed it it smokes like a damn freight train at start up and then once it warmed up it was good until you got it to about 2k RPM. At that point it lost all power and smoked like crazy again. The smoke was white so that made me think fuel problem. Got it back to my house 2 miles from the garage and changed the fuel filter and dumped injector cleaner in since it was sitting for about a year since it was last started. When I change the fuel filter, I have the habit of filling that reservoir with fuel just so it wont have a dry start. Probably paranoid but w/e. The truck started and idled for about five minutes when it started to knock and smoke really bad again. Stalled out and wouldnt start afterwards. I then noticed that when I turned the key on there was no sound from the fuel pump. I put an extra one on that I knew was still good from another wrecked truck and still nothing.
Unless I over looked a fuse somehow, they all seemed to be good. My next step will be tomorrow when I test the wires where the plug connects to the wiring harness to see if there is power there.
Any thoughts on my pump problem? Did we miss something when we plugged all the wires in?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-17-2009, 04:36 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Location: Ringtown, PA
Posts: 618
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Lol I guess I put a cuss word in there where the smiley is? whoops
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:21 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors