Fuel Problem? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-25-2007, 10:11 PM Thread Starter
Powerstroke.org Rookie
Join Date: Feb 2007
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuel Problem?

I just started noticing this here recently in my 01 7.3. I own a pressure washing company and fully loaded, my trailer weighs about 10,000 pounds. When I get on the interstate trying to get up to speed, once I get to a little over half-throttle, it seems as if I can't get any more power. You can put your foot in the floor and it will keep slowly gaining speed, but thats it. The rpm's don't change or anything. So, the next time I dropped my trailer, I tried it again empty and it did the same thing. Once I get up to about 55/60, I can't get any thing more out of it. It's like it doesn't respond to what I'm trying to get it to do. Checked the computer and no history codes are showing. Could this be a safety thing with the computer or what cause it sure as hell doesn't seem like that's what it ought to be doing.
LA Pressure is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome