7.3L power stroke help needed - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-07-2009, 03:14 PM Thread Starter
Powerstroke.org Rookie
Join Date: Sep 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3L power stroke help needed

the hpop to front cover gasket was leaking so i took everything apart , got the 3 oring replacement kit for the pump itself, noticed that the plug under neith the two outlet fittings was squished out, took the plug out to find out that a squad rod and a ball bearing came out with it. i then placed the ball bearing back and the rod as well then the new oring a plug with a needle on it. put everything back together. wouldnt start, removed both outlet lines and only oil is coming out of the back outlet port which goes to the passenger head and no oil is coming out of the fitting for the driver head. can anyone please help me with this, did i assemble the plug with the needle and rod and bearing wrong? i didnt take anything else apart.
powerstroker2002 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome