It lives again, but... - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-06-2009, 12:53 PM Thread Starter
Serving Our Country!
Join Date: Sep 2007
Location: Middleburg, FL
Posts: 370
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
It lives again, but...

Finally got the truck started with some family help; put in a new fuel filter and used starting fluid sprayed into the compressor. The only problem is it won't start when cold and it takes about 5 seconds when hot (sounds like it's struggles a bit, as well). I keep having to pull the air cleaner tube to spray the fluid, which is a PITA. Both batteries checked out good.

I've read to check the glow plug relay, the injection drive module and the starter relay, among other components. How do you check:
- glow plug relay key on/off?
- IDM?

Thanks for the help. This truck is driving me nuts!!!

F250 sold.
nc1500 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome