*HELP* URGENT!! - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-03-2009, 09:14 AM Thread Starter
Compression Ignition Addict
 
blowinsmoke7.3's Avatar
 
Join Date: Jan 2008
Location: Lincoln Texas
Posts: 1,468
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
*HELP* URGENT!!

I'm having some issues when the trucks at idle.
Real choppy, lopey idle, almost stalls out
Throwing the ses light
NO POWER @ idle
*it is not all the time, intermittent problem*

I know I need to get it on a scanner hence the ses light but being in college pt and working pt it's hard to find time.
I'm going to start by checking all sensors for a snug connection as for what to do after that I'm lost??

Anyone expierienced these symptoms? Any help is appreciated thanks

99.5 F-250 Lariat 4x4 CC
-Isspro's in A-pillar
-5" TB into 6" miter
-Recon smoked cab lights
-Bullydog "mileage" chip *Matts tunes in 2 weeks*
-Warn hubs
-DIY intake, Foil delete
-Hankook MT 285's
blowinsmoke7.3 is offline  
post #2 of 4 Old 09-03-2009, 11:00 AM
Compression Ignition Addict
 
Nosparkplugs's Avatar
 
Join Date: Apr 2008
Location: East central IL
Posts: 218
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
see if theres oil in the icp, make sure battery cables r tight its a start anyway

Early 99 f-250 cab and half longbed 4" intake and exhaust edge evolution II(for egt and boost guage only), trans temp guage trucool max 40K, TW 6 pos
Nosparkplugs is offline  
post #3 of 4 Old 09-03-2009, 11:10 AM
Compression Ignition Addict
 
Black&Gold's Avatar
 
Join Date: Jan 2008
Location: Richardson
Posts: 985
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Black&Gold Send a message via Skype™ to Black&Gold
i had the same thing happen to me, it was the ICP sensor. mine had oil in it and that is a key sign that it has failed. also once i installed the new one it did it to me again, but it was just the connector being loose. good luck.

SOLD... LOOKING FOR A 6.7L OR 6.4L CC SB MUST BE CLEAN!!!
Black&Gold is offline  
post #4 of 4 Old 09-03-2009, 02:38 PM Thread Starter
Compression Ignition Addict
 
blowinsmoke7.3's Avatar
 
Join Date: Jan 2008
Location: Lincoln Texas
Posts: 1,468
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
After checking my icp it was not firmly seated on the cup. No issues yet

99.5 F-250 Lariat 4x4 CC
-Isspro's in A-pillar
-5" TB into 6" miter
-Recon smoked cab lights
-Bullydog "mileage" chip *Matts tunes in 2 weeks*
-Warn hubs
-DIY intake, Foil delete
-Hankook MT 285's
blowinsmoke7.3 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome