Boost Dropping Out! Help!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-25-2009, 05:18 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: Arco Idaho
Posts: 369
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Boost Dropping Out! Help!!

Here are the symptoms, when the boost reaches 18 psi it completely drops out to zero and then only comes back to about 8 psi. It feels like all of my boost just disappears, but I still have all of the fuel. It also smokes like nobody's business when this occurs, I am guess because of the lack of air. Any idea what is wrong with my truck! Thanks in advance fellas. Let me know if you need more info to help me.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-25-2009, 05:21 PM
Premium Member
 

Join Date: Jun 2009
Location: Connecticut
Posts: 1,194
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like a wastegate malfunction?
Reply With Quote Quick reply to this message
  #3  
Old 08-25-2009, 05:22 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: Arco Idaho
Posts: 369
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Honestly that's what it feels like, and thats what I thought but I figured I would see what you all thought. It feels like maybe I have a broken internal component that works occasionally and then sometimes gives away, maybe the spring.
Reply With Quote Quick reply to this message
  #4  
Old 09-01-2009, 05:51 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: Arco Idaho
Posts: 369
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Still loosing my boost around 20psi even with the waste gate wired shut. Here is the symptoms again, the truck spools up to 20psi and as soon as it reaches that the boost drops back down to 10 and then slowly crawls back up to 20 and repeats. It also makes a choppy shutter noise on the drivers side and I can feel a vibration when it happens. Any help would be greatly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:53 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors