loss of power and horrible idle - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-12-2009, 06:07 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
loss of power and horrible idle

First post and this isn't a good start. today at work my 99 F250 had no power and a rough idle. it is almost as if it is running lean. there is a loud knocking at idle but no check engine light and it scans clean for codes. it is a stick shift and didnt have enough power to get out of low gear. it is completely stock with 147,000 miles and a 4 inch turbo back diamondeye exhaust. i had to have it towed back to my house and am afraid to even try and crank it back up. i am new to diesels and any help would be wonderful. by the way i have always taken care of this truck and never ragged it or let it run low on fuel or oil. i change everything regularly and this has just stumped me.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-13-2009, 10:47 AM
Compression Ignition Addict
 

Join Date: Aug 2009
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok i talked to one of my diesel buddies and he suggested checking the fuel system. i drained the bowl and noticed the fuel was a little dirty and that the filter was a lot dirtier than it was two weeks ago. now when i try to crank the truck it isn't getting any fuel to the bowl. could this be a fuel pump or a fuel pickup or what
Reply With Quote Quick reply to this message
  #3  
Old 09-23-2009, 06:21 PM
Member
 

Join Date: Jul 2009
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hi, check the "socks" in the fuel sending unit (inside the tank) If their dirty the tank is rusting out, just toss them and put an inline filter before the pump
Reply With Quote Quick reply to this message
  #4  
Old 10-06-2009, 07:02 PM
Compression Ignition Addict
 

Join Date: Mar 2008
Location: Round Rock
Posts: 316
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine did same thing to me today but died and wont start very loud nocking when cranking, i have good clean fuel as far as I can tell, just had LPOP replaced about 4 months ago dont mean to still the thread but need help cant afford wat shop charges right now im thinking high pressure oil system but dont have now how to check without a very expensive scanner, hooked programmer up and no DTC's
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:52 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors