dying/stalling - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-29-2009, 02:03 AM
Powerstroke.org Rookie
 

Join Date: Jul 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
dying/stalling

hello all i am new to the site but have had PSD for a while. i am fairly knowledgeable when it comes to working on my 99 7.3.

i recently had my trans rebuilt after finding my torque converter blewup anyways shortly after having the work done out of the clear blue the engine starts dying. every once in awhile in will throw a CEL but will go away after turing off the IGN. there is no pattern to when it dies, and always starts back up sometimes with hesitation. It will completely dye when coming to a stop or slowing down, and as im going down the road it will shutter like it wants to die at least every time i start it.

i have been reading all the threads and the only thing i can gather is that it might be the CPS, the engine has 145,000 w/ a diesel innovations chip . can anyone else give me any other ideas.

thanks Chad
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-29-2009, 04:57 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Jefferson, Ga
Posts: 673
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Definite cam sensor possibility. I would check codes to see what the CEL has been logging so you don't buy something you don't need. But at $25 and about 10 minutes it never hurts to install the new cam sensor.
Reply With Quote Quick reply to this message
  #3  
Old 07-29-2009, 05:04 PM
Compression Ignition Addict
 

Join Date: May 2008
Location: Albuquerque
Posts: 781
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
That sounds like i could be the tc locking up all of the time for some reason. If i were you i would get the code out of the truck asap. you can go to autozone and have them pull the code for you. and if the tranny is new then it should have a warranty and the shop that built it would have to do the wrok for free. Not saying this is the problem but very well could be good luck man.
Reply With Quote Quick reply to this message
  #4  
Old 07-31-2009, 01:47 PM
Powerstroke.org Rookie
 

Join Date: Jul 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok took the truck to the dealer and had them install a new CPS under a recall from ford and it fixed the problem, thanks for the input guys.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors