Rough running 97 - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-08-2007, 07:15 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Location: Mantorville
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Rough running 97

New to the forum,
I recently purchased a 97 250 PSD. It seems to have a miss when ever you accelerate, it also blows white smoke during acceleration. It seems to smooth out after you are up to speed or not on the pedal. Not sure what it could be, any help would be greatfull.

Also just replaced lift pump, Cam Sensor, oil and all filters none of which seemed to help. Thanks...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-08-2007, 07:47 PM
Nuckin' Futz


 

Join Date: Jul 2006
Posts: 700
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Have you had a cylinder contribution test or injector buzz test done...it seems to me like one or more of your injectors is leaking..either the orings on the out side of the injector or it is stuck open. Any codes?
Reply With Quote Quick reply to this message
  #3  
Old 02-09-2007, 03:49 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Location: Mantorville
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No I have not done any of these tests. I am still waiting for the title for the truck so I have just been putting the problem off. I will look in to getting those done though, not sure what it requires to do these tests???
Reply With Quote Quick reply to this message
  #4  
Old 02-09-2007, 05:44 PM
Nuckin' Futz


 

Join Date: Jul 2006
Posts: 700
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
pretty much just a scan tool...what a cylinder contribution test is is the scan tool will shut down each injector during a duty cycle...this shows it which cylinders are lagging behind and not really contributing...the buzz test is where the scan tool activates...or buzzes...the injectors to make sure they are all working properly...this can tell you if an injector is stuck open.
Reply With Quote Quick reply to this message
  #5  
Old 03-12-2007, 07:05 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Location: Mantorville
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Replaced all 8 injectors with rebuilt ones, Truck runs allot better but it still has a little miss and white smoke when you accelerate. It is not very noticeable, only when you rev the engine up at a stop. Just wondering if I could still have a bad injector or if it could be another problem....Thanks
Reply With Quote Quick reply to this message
  #6  
Old 03-12-2007, 07:59 PM
Nuckin' Futz


 

Join Date: Jul 2006
Posts: 700
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Im wondering how your injector wiring harness is then...cause if they are "new" then they shouldn't be bad...i wonder if the signal isn't being transmitted properly. Or you could still have a bad injector...just cause they were rebuilt doesn't mean they were rebuilt correctly
Reply With Quote Quick reply to this message
  #7  
Old 03-15-2007, 04:38 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Location: Mantorville
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The valve cover gasket conections look good, I am not sure about the rest of the harness, I checked the ressistance back through the harness and from what I was told (I forget how many ohms it was) they were all good.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:45 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors