Popping noise in the front end! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-13-2013, 10:53 AM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Popping noise in the front end!

Hello everyone,
I own a 2000 f250 ext cab long bed 4x4 with the 7.3 ltr. I was having some popping noises comming from the front of the truck it feels like it under my feet on the driverside. I replaced upper and lower ball joints, hub bearing assemblies on both sides and sway bar bushings and end links, also tightened up the body mount bolts. Everything seemed to help alot but still get a slight popping noise driving straight semi bumpy road. Any suggestions? Thank you!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-16-2013, 06:09 AM
Serving Our Country!
 

Join Date: Dec 2012
Location: Middle tennessee
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the same thing happening.... I think its something with my leaf springs now. I replaced shocks new steering stabilizer. I see you replaced all of that and it still does it...
Reply With Quote Quick reply to this message
  #3  
Old 05-14-2013, 09:46 AM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Covina CA
Posts: 596
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check the track bar and its mounts, they like to make noise if anything is loose
Reply With Quote Quick reply to this message
  #4  
Old 05-28-2013, 10:08 AM
Member
 

Join Date: Apr 2007
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the brackets on the tie rod and drag link, mine was doing that and thats what it was, there is a bracket on i think it's the drag link and it catches on i believe the tie rod or another bracket on the tie rod. I had the problem for years untill i happened to be under the truck and the tires were turned at just the right angle to see that they could kinda catch. I ground a little off the bracket and no poping since.
Reply With Quote Quick reply to this message
  #5  
Old 06-24-2013, 04:53 PM
Serving Our Country!
 

Join Date: Oct 2009
Posts: 459
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the same problem. It was the leaf springs. They are rubbing against eachother and kind of binding up and then letting go, hence the pop. I stopped washing them and it seems the dirt in between them has buffered it and it doesn't do it hardly as often as it used to.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:40 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors