Wheel bearing hub going bad? - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-06-2012, 07:32 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Wheel bearing hub going bad?

I was greasing ball joints, tie rods, ECT and noticed that when you spin the left front tire you can hear a clicking from the wheel bearing accompanied by a slight grinding from pad/rotor contact. But it's not constant it clicks and grinds on a portion of the 360 degree spin almost like the rotor was warped but they are powerslot cryo rotors and hawk pads with maybe 10,000miles on them. the pads are wearing very very tiny bit unevenly but there is no play in the wheel bearing.

Time for a new hub/bearing?

john6200 is offline  
post #2 of 2 Old 04-06-2012, 05:21 PM
Compression Ignition Addict
 
Join Date: Mar 2011
Posts: 990
Thanks: 0
Thanked 9 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 12 Post(s)
Feedback Score: 0 reviews
Pull the wheel and brakes off and check the hub directly.
ttyR2 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome