Major Issue with Hub - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-15-2012, 06:56 PM
Premium Member
 

Join Date: Nov 2010
Posts: 120
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Major Issue with Hub

Guys I need help bad...I bought a set of Warn hubs to replace the factory autolock hubs. I sprayed both hubs with PB Blaster every night for about a week to loosen them up. Anyways, drivers side was easy as pie. Fast forward to the passenger side. Took the retaining ring out, tapped lightly on the hub on both sides, tried to wiggle the hub out and it wouldn't budge at all. Sprayed with PB Blaster again, let soak, still nothing. Tapped a little harder on the hub and it actually cracked the housing. So now I can't get the hub out, and I don't want to tap on it anymore and completely break the hub apart. What should I do?

Eric
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-15-2012, 07:08 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Ashippun, WI
Posts: 209
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tap it hard and let it break away......You have new ones right? But before you go to put in the new one I would sure figure out why the old one wouldn't come out. Bad axle shaft putting pressure on the splines? Bad hub bearings? Something isn't right there, and I don't think it is just corrosion. Good luck.
Reply With Quote Quick reply to this message
  #3  
Old 01-21-2012, 09:22 PM
Johnny Law Brown

 

Join Date: Sep 2008
Location: Tipton, IN
Posts: 366
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I have seen them things come out real hard before they make a tool to remove them but I usually just put atwo pair of vise grips on each side lock em down tight and pull hard and hope I don't fall off my seat
Reply With Quote Quick reply to this message
  #4  
Old 01-21-2012, 10:27 PM
Premium Member
 

Join Date: Nov 2010
Posts: 120
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've tried two pairs of vise grips and hoping they don't slip...I think I'm going to ruin a couple pairs and weld a plate between them to connect a slide hammer to and try to get it out that way...snow is coming so I need to get it done asap. Thanks guys.

Eric
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:28 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors