Weak rear brakes - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-01-2011, 07:46 AM Thread Starter
Powerstroke.org Rookie
Join Date: Dec 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Weak rear brakes

I have a 99.5 Cab and Chassis truck, DRW with a 6 speed. I am hardly getting any braking from the rear brakes. With a light snow on the ground, I stomp on the brake pedal and the front lockup (as much as the ABS lets them) but the rears dont. I verified this by checking the snow after stopping the truck. Perfect tread pattern for the rears, skid marks for the front. From looking at the brake rotors the rear brakes are hardly working, there are still light rust outlines of the pads from when the truck sat for a while. I would have expected those to have worn off completly after driving the truck for a month. Where as the front are nice and shiny and no marks left.

I plan on pulling the ABS fuse and see if results change. But I thougth I would see if anybody here has had a similar problem.

engnerdan is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome