front end popping/shaking - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-09-2010, 10:38 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 185
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
front end popping/shaking

Lately Ive been hearing a loud clicking/popping sound coming from around the right front tire. You can hear it clearly and feel it in the truck, and it seems to speed up the faster you go. Just yesterday I was driving and once you get up to speed you don't notice it that much but as soon as I hit the first decent bump the entire front end went into a violent shake that you can tell is coming from the right front. The shake doesnt stop until you come to a complete stop. And then it will click while taking off and it doesnt start doing the violent shaking until I hit anotherbump. Any ideas about what this could be?
Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-09-2010, 11:16 AM
Member
 

Join Date: Jul 2010
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Are you lifted? I had this same situation with my truck i was lifted on 41's i installed the Icon Adjustable Stablizer bar and that seemed to correct the situation..

TwEaK
Reply With Quote Quick reply to this message
  #3  
Old 07-09-2010, 11:58 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 185
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no lift its all stock. WHich one is the stabilzer bar? I've taken off the front wheel and you cant tell that anything is wrong, there is no play in any of the bars underneath or near the front axle except the one closest to the front of the truck? It has a little play back and forth and makes somewhat of a popping noise but I don't see how this would cause the problem?
Reply With Quote Quick reply to this message
  #4  
Old 07-09-2010, 02:28 PM
Member
 

Join Date: Jul 2010
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thats the one its the bar that has no adjustment on it. It runs parallel with the drag link check the bushings.. mine's was extremely sloppy after replacing it with the ICON never had an issue again

TwEaK
Reply With Quote Quick reply to this message
  #5  
Old 07-09-2010, 02:30 PM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 30,944
Thanks: 105
Thanked 88 Times in 82 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Couple things to check. Sway bar bushings. Ball Joints and wheel bearings. Track bar as well
Reply With Quote Quick reply to this message
  #6  
Old 07-09-2010, 02:31 PM
Serving Our Country!
 

Join Date: Jul 2007
Location: Great Falls, MONTANA
Posts: 1,164
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
stupid question maybe but it happen to me are your lug nuts tight????
Reply With Quote Quick reply to this message
  #7  
Old 07-09-2010, 02:42 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 185
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The lugnuts are tight, how should I go about checking the sway bar bushings, the track bar, wheel bearings, and ball joints?
Thanks
Reply With Quote Quick reply to this message
  #8  
Old 07-09-2010, 02:52 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 185
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The only bar with any slop or play in it is thatone that is farthest towards the front. I bought the truck used, but everything under the front has been replaced with moog parts that are all greaseable including the ball joints. Does that help narrow it down any?
Thanks for the help
Reply With Quote Quick reply to this message
  #9  
Old 07-09-2010, 03:20 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 185
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just went to check the u joint and it seems fine but the u joint does rub on the bottom of the ball joint, its not horrible damage but you can tell that it does rub and that was with the right front end jacked up so maybe this is the problem, but what would cause the u joint to rub on the bottom of the ball joint?
Reply With Quote Quick reply to this message
  #10  
Old 07-09-2010, 03:43 PM
Member
 

Join Date: Jul 2010
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i had the same issue with the moog balljoints hitting my Ujoint i really didnt worry about it but yes the Track bar is what i had to replace on my truck..

TwEaK
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:24 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors