Need help with e-brake problem - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-02-2010, 10:33 PM Thread Starter
mustang2002's Avatar
Join Date: Jul 2009
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need help with e-brake problem

Hea whats up ive got a 2002 f-550 wrecker my problem is when i engage the ebrake it dosent work and the peddle is very hard to press .

i have replaced the parking shoe's and also adjusted them got them to work but the peddle is still very hard to push and it dosent really work in reverse . it holds okea forward now but still not 100%

i was thinking maybe the cables need replacement but i wanna see what others think or maybe someone has had the same problem ect

Thanbks for any help givin
mustang2002 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome