95 7.3 starting rpms - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-26-2014, 04:59 PM
Member
 

Join Date: Dec 2013
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
95 7.3 starting rpms

I have a no start, cranks and cranks. White smoke pours out. It smells like diesel. Only getting 149 rpms when cranking. Any thoughts??

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-27-2014, 08:57 AM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,825
Thanks: 0
Thanked 43 Times in 43 Posts
Feedback Score: 0 reviews
Is the CEL illuminated? If you are getting white smoke, that would indicate that your HP oil system is generating enough pressure to tell the PCM to actuate the injectors. You might want to check the voltage drop across the glowplug relay's large terminals (place voltmeter leads on the large terminals while relay is active ... more than 0.3V and the relay is bad). You could also try plugging the block heater in for about 3 hours and see what happens. Cheers!
Reply With Quote Quick reply to this message
  #3  
Old 07-27-2014, 09:58 AM
Member
 

Join Date: Dec 2013
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tried the block heater, its like 70s here. Glow plug is bad. I am replacing it. But I don't think I need it to start. I feel like its not turning fat enough

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 07-28-2014, 06:38 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 1,825
Thanks: 0
Thanked 43 Times in 43 Posts
Feedback Score: 0 reviews
Check the batteries and the starter. The starters do degrade over time (slow enough of a degrade where you don't really notice). FWIW, my truck wouldn't start on a July day when my relay went south many years ago. Cheers!
Reply With Quote Quick reply to this message
  #5  
Old 07-31-2014, 06:43 PM
Member
 

Join Date: Dec 2013
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Replaced starter. Turns over way better now. I tested batteries. They are good. Waiting on relay. I mean what else could be? Starter doesn't sound like cylinder is missing compression. I got 3000ish injection pressure, but IPR jumps to also 50% though

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors