Annoying check engine light. HELP!!! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-06-2014, 11:45 AM Thread Starter
Member
 
Farley95Stroke's Avatar
 
Join Date: Mar 2014
Posts: 40
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Annoying check engine light. HELP!!!

Hey guys. I have a 1995 f250, with 246xxx miles that i believe has a sensor that's going bad. almost every time when i start the check engine light comes on. It goes off within a minute or so of the truck running, but when it goes off the trucks RPMs surge and either it stays running or dies. I cant imagine that this is good for my truck. I figured it is a sensor. The only code that i'm throwing is P1280. Could this be the ICP?? If i left out something vital please ask me. Thanks in advance.
-Josh
Farley95Stroke is offline  
post #2 of 4 Old 05-06-2014, 11:59 AM
Compression Ignition Addict

 
sbluke55's Avatar
 
Join Date: Sep 2013
Location: Grand Junction, CO
Posts: 6,937
Thanks: 289
Thanked 544 Times in 516 Posts
Mentioned: 12 Post(s)
Quoted: 415 Post(s)
Garage
Feedback Score: 1 reviews
Unplug your icp and see if there is oil in the plug. If there is, replace the pig tail and icp.

01 f-250, Standard
Rev tech 4" lift,37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks inner cooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
sbluke55 is online now  
post #3 of 4 Old 05-06-2014, 03:45 PM Thread Starter
Member
 
Farley95Stroke's Avatar
 
Join Date: Mar 2014
Posts: 40
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It is leaking oil fairly bad. Has anyone else ever heard of this sensor being bad with my symptoms before?Im gonna change any way, just curious.
Farley95Stroke is offline  
post #4 of 4 Old 05-06-2014, 04:17 PM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,226
Thanks: 0
Thanked 86 Times in 84 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
Yes, your symptoms are common with a bad ICP. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome