truck stumbling. - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-06-2014, 08:19 PM Thread Starter
Compression Ignition Addict
 
sethc24's Avatar
 
Join Date: Sep 2009
Posts: 421
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
truck stumbling.

Hey guys I got a 1997 f250 7.3 auto 4x4. 228,000 miles. Anyways for a while the truck would stumble when I would first start driving it wheither the engine was cold or warm. It would rev up too 1900 rpm but no more and build no boost for about 5-10 seconds and than it would clear up and run fine. Today it did the same thing but the check engine light came on and the truck lost power. There is a dead spot on the tps assembly right at the beginning. ( not sure if that helps). I replaced the cps sensor with a grey motorcraft one a few months back. I have heard this could be caused by bad injector O-rings is there anything I should check before I dive in headfirst?

1997 F-250 4x4. 5 speed, 6637,exhaust,dp-tuner,dana 60, 33's
sethc24 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome