really bad diesel fuel smell - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-15-2008, 08:00 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Versailles KY
Posts: 429
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation really bad diesel fuel smell

for some reason my truck smells like diesel fuel really bad, ive checked all over the truck for leaks but didn't find any. it does leak some oil, its a 1996 ford f250. does anyone have any suggestions to the problem?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-15-2008, 08:41 PM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: Vail, AZ
Posts: 4,507
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to ford_trck
My buddies 96 is the same way. He gets a leak often on the fuel pump or something that has 2 copper washers. I figured it smelled because the valley was coated in diesel but I dunno.
Reply With Quote Quick reply to this message
  #3  
Old 11-15-2008, 08:51 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Versailles KY
Posts: 429
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ill probably going to have to check under the hood a few more times, I noticed that it only smells really bad when its running so it could be the pump.
Reply With Quote Quick reply to this message
  #4  
Old 11-15-2008, 10:18 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Ponchatoula, Louisiana
Posts: 986
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the all of the rubber fuel lines that are in the valley of the engine. They tend to rot after 12 years.
Reply With Quote Quick reply to this message
  #5  
Old 11-16-2008, 05:48 AM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Versailles KY
Posts: 429
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ya i should check those too, I don't think those have been replaced on my truck yet
Reply With Quote Quick reply to this message
  #6  
Old 11-16-2008, 06:17 AM
Premium Member
 

Join Date: Nov 2008
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check the sensor on the back of the fuel bowl. I've had the same problem. It
does'nt leak all the time so it took me a while to find it, but I had a fuel smell like you are having.
Reply With Quote Quick reply to this message
  #7  
Old 11-16-2008, 06:23 AM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Versailles KY
Posts: 429
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
is it easy to get to and fix?
Reply With Quote Quick reply to this message
  #8  
Old 11-17-2008, 04:52 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Memphis, TX
Posts: 1,372
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via AIM to Maverick1701
it took me a long time to find my leak...turns out the fuel pump was leaking from the weep hole. I am in mid-repair right now actually lol
Reply With Quote Quick reply to this message
  #9  
Old 11-17-2008, 06:10 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Versailles KY
Posts: 429
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ya ill probably have ot check my fuel pump too, I know something under my hood is leaking.
Reply With Quote Quick reply to this message
  #10  
Old 11-17-2008, 06:20 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Memphis, TX
Posts: 1,372
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via AIM to Maverick1701
Quote:
Originally Posted by ~NASTYSTROKER96~ View Post
ya ill probably have ot check my fuel pump too, I know something under my hood is leaking.
I had to grab a flashlight, crawl over the running engine and look way down into the vally of the engine to find my leak. I had been smelling fuel for a while and could never locate it. I sure hope you can find/fix the problem...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:03 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors