Truck died after fuel filter lite came on - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-16-2008, 02:23 PM Thread Starter
Premium Member
 
joseyaaron's Avatar
 
Join Date: Apr 2007
Location: Colchester, VT
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck died after fuel filter lite came on

I wasw driving my 96 F350 Crew cab power stroke home from a 160 mile road trip and the fuel filter light started flashing while climbing hills. It then came on steadily and the truck started to loose power. I went to pull to the side of the road and it died all together. I am currently running vegetable oil in the truck. I pulled the filter and cleaned it the best I could. I got nothing. I have it towed back to my shop. I pulled the fuel line by the left front wheel and used my suction gun to pull fuel through it. So I know it isn't the transfer switch or a clog in the the rear. It doen't seem to be getting any fuel into the filter housing. I changed the filter and filled the housing with fuel, and still nothing. Please help!!!!
joseyaaron is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-16-2008, 03:21 PM
Premium Member
 
Join Date: Jun 2008
Location: Around
Posts: 1,042
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
psd

plug truck in and see if that will help.
outlawdiesel is offline  
post #3 of 5 Old 08-16-2008, 09:18 PM Thread Starter
Premium Member
 
joseyaaron's Avatar
 
Join Date: Apr 2007
Location: Colchester, VT
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I will try that in the am
joseyaaron is offline  
post #4 of 5 Old 08-17-2008, 12:54 AM
Premium Member
 
Join Date: Jun 2008
Location: Around
Posts: 1,042
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
psd

it sounds like there is a clog somewhere . so i thought if you plug it in, it would thin out the fuel.so the clogged line would blow through.
outlawdiesel is offline  
post #5 of 5 Old 08-24-2008, 05:17 PM
Powerstroke.org Fanatic
 
Join Date: Sep 2007
Posts: 120
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have you checked your fuel pressure at the schrader valve? It could be the fuel pump, IPR, IPC sensor, HPOP, or low oil. That's all I can think of. A problem with the IPR or IPC should throw a code, but the others might not.
cfunderb is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome