no brake or turn lights help please - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 11-16-2013, 12:29 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
no brake or turn lights help please

i have a 95 f350 crew cab dually i recently converted to 4wd
my problem is just yesterday i lost turn signals and brake lights but have running lights.
all my fuses are good my lights go off the same light because i have a flat bed my wiring is all good the turn lights on the dash do not come on i put a new multifunction switch on and still have nothing any idea what it could be sorry about my typing
smforever is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-16-2013, 04:43 PM
Member
 
Vicmillon's Avatar
 
Join Date: Nov 2012
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I had a similar problem that was a loose cable on the brake pedal.
ABS light came on?
Manual or auto? Can you start the truck and shift into D?
Vicmillon is offline  
post #3 of 6 Old 11-16-2013, 05:06 PM
Compression Ignition Addict
 
2000-7.3L's Avatar
 
Join Date: Aug 2012
Posts: 4,167
Thanks: 1
Thanked 16 Times in 16 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 10 reviews
Multi function switch aka blinker switch! Problem solved!
2000-7.3L is offline  
post #4 of 6 Old 11-16-2013, 06:20 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ABS light came on. I switched the multifunction switch all connectors are hooked up ABS light is off i have brake lights but still no turn signals i can start the truck and yes because its a 5 speed.
smforever is offline  
post #5 of 6 Old 11-17-2013, 10:15 AM
Member
 
Vicmillon's Avatar
 
Join Date: Nov 2012
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Did you check fuses on engine box and driver panel?
Vicmillon is offline  
post #6 of 6 Old 11-17-2013, 05:40 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yes the fuses were checked I still only have stop and running lights no turn lights and no turn lights on the dash
smforever is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome