Power steering pump - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 10-28-2013, 03:02 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Power steering pump

Hey y'all, yeah I'm a newbie here...
My rig is pretty stock 96 F350 and developed
A loud knock last Friday. I pinpointed to
the PS pump. By the time I got home slowing
to a stop it sounded like a coffee can full of
marbles. Under power it didn't make the knock.
When I held the pressure hose it was like
the thing was dead heading instead of flowing.
I replaced the pump Saturday and ran it Sat/Sun
All seemed good, until this morning. I have the
same issues u had last week. Could I be getting
contamination from the steering gear; like
Pcs of metal??? Hate to replace another pump
and get same results. Thanks for any ideas
Az SON is offline  
post #2 of 9 Old 10-28-2013, 05:36 PM
Compression Ignition Addict
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 3,856
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Thanks: 4
Thanked 126 Times in 122 Posts
Feedback Score: 0 reviews
How did the fluid look in the old pump?

You did refill it with ATF, right?
madpogue is offline  
post #3 of 9 Old 10-28-2013, 07:12 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yes replaced w ATF, old fluid dark red. After looking and listening more this evening I'm leaning more towards a pulley? Heck idk, tomorrow I'll light it off w/o the belt and start from there. At idle it and coming off of the accelerator is when it sounds like a spoon is in the garbage disposal. Increase rpm and it stops. Def coming from front of motor and on the topside. Idk if it's the PS pump....any input is appreciated
Az SON is offline  
post #4 of 9 Old 10-28-2013, 07:25 PM
Compression Ignition Addict
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 3,856
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Thanks: 4
Thanked 126 Times in 122 Posts
Feedback Score: 0 reviews
Are you sure it's not just a weak tensioner spring, and thus the belt flapping?
madpogue is offline  
post #5 of 9 Old 10-28-2013, 08:02 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I looked at the tension and thought it strange to hop a bit. I went back through my paperwork and that part replaced before. Can't hurt to change it if it's weak
Az SON is offline  
post #6 of 9 Old 10-29-2013, 07:07 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok so changed tensioner assembly and all was good until she warmed up, knocking and rattling again. To save me some piece of mind I pulled the belt and fired her up. Same knocking and rattling coming from between alternator and AC comp. chasing what seemed to be a simple issue and now it's internal...any thoughts?
Az SON is offline  
post #7 of 9 Old 10-29-2013, 07:33 PM
Powerstroke.org Sponsor

 
Corey@CNCFAB's Avatar
 
Join Date: Apr 2010
Location: Defiance, OH
Posts: 9,127
Mentioned: 127 Post(s)
Tagged: 1 Thread(s)
Quoted: 353 Post(s)
Thanks: 751
Thanked 485 Times in 441 Posts
Feedback Score: 1 reviews
HPOP or cam gear

Sent from AutoGuide.com Free App

E99CCLB 250/200s,STG1cam, KC38R, 4" exh,CNC FAB fuel&oil lines,140vIDM,BTS,S&B

97 ECLB F250 4x4 all stock
96 CCLB F350 4x4 D60 swap stock



EDGE,S&B,SCT,PHP Hydra,TS-Perf,OEM parts,Sam Wyse trans,VB's,LED's,MBRP,ISSPRO,ICON,FOX,KC TURBOs,SD 7.3 fuel kits, HPOP lines

www.cncfab.us or email sales@cncfab.us

Corey@CNCFAB is offline  
post #8 of 9 Old 10-29-2013, 07:36 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How can I confirm which is the culprit? As stated before only knocks at idle, decelerating. Does not knock accelerating or under load
Az SON is offline  
post #9 of 9 Old 11-04-2013, 01:33 AM
Powerstroke.org Sponsor

 
Corey@CNCFAB's Avatar
 
Join Date: Apr 2010
Location: Defiance, OH
Posts: 9,127
Mentioned: 127 Post(s)
Tagged: 1 Thread(s)
Quoted: 353 Post(s)
Thanks: 751
Thanked 485 Times in 441 Posts
Feedback Score: 1 reviews
Remove the HPOP gear access cover on the front of the engine. The one that your EBPS bracket is also attached to.

Sent from AutoGuide.com Free App

E99CCLB 250/200s,STG1cam, KC38R, 4" exh,CNC FAB fuel&oil lines,140vIDM,BTS,S&B

97 ECLB F250 4x4 all stock
96 CCLB F350 4x4 D60 swap stock



EDGE,S&B,SCT,PHP Hydra,TS-Perf,OEM parts,Sam Wyse trans,VB's,LED's,MBRP,ISSPRO,ICON,FOX,KC TURBOs,SD 7.3 fuel kits, HPOP lines

www.cncfab.us or email sales@cncfab.us

Corey@CNCFAB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome