stalling help!!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-18-2008, 06:33 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
stalling help!!!!

hello all and thanks in advance for any help
so i have a 95 7.3 and it keeps stalling on me i have read all about the cps and am about to change mine tomorrow...that being said my truck is not having the same symptoms that i have read with other peoples cps going bad. my truck will always start right after it dies, it even does these really harsh studders at highway speeds the best way i can describe it is like the fuel cuts out for a couple of seconds and then it is back. it dies a lot at low rpm i can just pop it into neutral and it will fire right back up. it has never triggered the check engine light so im gonna assume that it is not tripping any codes. like i said im gonna change the cps tonight or tomorrow. if anyone can think of anything else i would greatly appreciate it
thanks
shan
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-19-2008, 12:39 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Eugene Oregon
Posts: 503
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
your cps sensor may not be generating the correct magnetic field or the clearence is off between the pickup surfaces. check the volts going to the sensor
Reply With Quote Quick reply to this message
  #3  
Old 07-19-2008, 01:31 PM
Premium Member
 

Join Date: Jun 2008
Location: Around
Posts: 1,042
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thumbs up fix psd

it sounds like cps or battery cables.
Reply With Quote Quick reply to this message
  #4  
Old 07-19-2008, 01:57 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
replaced the cps last night and has not stalled or lurched all day.....i'll keep my fingers crossed. i had thought of battery issues but everything else stays on it seems to only be engine related. hopefully they cps has done the trick i'll post back in a few days with the results.
thanks for the input guys!
Reply With Quote Quick reply to this message
  #5  
Old 07-20-2008, 07:00 PM
Powerstroke.org Rookie
 

Join Date: Mar 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
dies but start right back up

my pickup dies but starts right back up. idles fine and runs fine starts easy, shows no loss of power but shuts down every once in a while. what do i need to check.
Reply With Quote Quick reply to this message
  #6  
Old 07-20-2008, 07:04 PM
Premium Member
 

Join Date: Jun 2008
Location: Around
Posts: 1,042
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thumbs up psd

buy a new cps.
Reply With Quote Quick reply to this message
  #7  
Old 07-20-2008, 07:04 PM
Shade tree mechanic


 

Join Date: Mar 2008
Location: Lake Tapps, Wa.
Posts: 8,284
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by michael76 View Post
my pickup dies but starts right back up. idles fine and runs fine starts easy, shows no loss of power but shuts down every once in a while. what do i need to check.
start a new thread, tell us about your problem, and we will all be glad to help you man.
Reply With Quote Quick reply to this message
  #8  
Old 07-20-2008, 07:08 PM
Premium Member
 

Join Date: Jun 2008
Location: Around
Posts: 1,042
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thumbs up psd

sorry about that,thought it was the same guy.please let us know more about your truck?
Reply With Quote Quick reply to this message
  #9  
Old 07-28-2008, 10:59 AM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
same prob. but fixed!!

hi, i had the same prob. but the cps didnt fix mine. i ended up having to put a new fuel pedal assembly on it. the one with sensor...payed 75 bucks at salvage yard....my prob fixed!!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:17 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors