losing power? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-18-2008, 02:17 PM
Member
 

Join Date: Sep 2007
Location: New River
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
losing power?

I have a 96 with 306,000 miles on it. Engine never been rebuilt, new injectors at about 240,000, DIY intake, 3" down pipe and 4" exhaust, edge EZF1000. It seems like I have been slowly losing power over the last year. I pull a 6000# trailer daily, and its not pulling up mountain hills as good as it used too. Any thoughts as to what it may be? And also when I put the chip above setting 2 it sputters going up hill like its running out of fuel.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-20-2008, 06:14 PM
Member
 

Join Date: Sep 2007
Location: New River
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anybody? bump
Reply With Quote Quick reply to this message
  #3  
Old 07-20-2008, 08:24 PM
Powerstroke.org Rookie
 

Join Date: Oct 2007
Location: Mentone Beach,Ca
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have you checked your fuel filter? i had a simular problem that ended up being the lift pump in the valley between the heads
Reply With Quote Quick reply to this message
  #4  
Old 07-21-2008, 07:30 AM
Member
 

Join Date: Feb 2008
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
we had this problem...ended up being a bad thermostat.
Reply With Quote Quick reply to this message
  #5  
Old 07-21-2008, 03:03 PM
Member
 

Join Date: Sep 2007
Location: New River
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
fuel filter good, Ill check out these other things thanks
Reply With Quote Quick reply to this message
  #6  
Old 07-22-2008, 05:48 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2008
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
This sounds very similar to the problem I am currently having. It does the same thing with the chip and stumbles on anything over the second setting. I've been trying to chase it down for about six months now with no real luck.....I hope someone can help.
Reply With Quote Quick reply to this message
  #7  
Old 07-22-2008, 05:49 PM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,177
Thanks: 116
Thanked 106 Times in 97 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
check fuel pressure. I bet the fuel pump and or HPOP are getting weak at that mileage
Reply With Quote Quick reply to this message
  #8  
Old 07-22-2008, 06:11 PM
Member
 

Join Date: Sep 2007
Location: New River
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
stinkers, I will let you know what i find out. I change fuel filter on regular bases so dont think thats it, but changed it and t stat today. Proly gonna stop by a shop tomorrow to have fuel pressure checked.
Reply With Quote Quick reply to this message
  #9  
Old 07-22-2008, 06:18 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2008
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks tinlizzy, I would really appreciate it. I changed the fuel filter today and cleaned out the fuel pressure regulator and it didn't make a difference on my truck. My fuel pressure at idle is good but I have no way of testing it under load.....but it has been a sneaking suspicion of mine that maybe it is crashing under load.
Reply With Quote Quick reply to this message
  #10  
Old 07-22-2008, 06:37 PM
Member
 

Join Date: Sep 2007
Location: New River
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Stinkers, how many miles on yer truck?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:08 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors