2 Problems - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 10-14-2013, 06:16 AM Thread Starter
Chapter Director

 
Rammstein1224's Avatar
 
Join Date: Aug 2012
Location: Davenport, IA
Posts: 2,931
Thanks: 4
Thanked 45 Times in 37 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
2 Problems

I took my 95 out on an actual trip this weekend and i got out to the highway and got up to speed and went to set the cruise and no dice. Well then i tried my horn and it too didnt work. I checked the fuse for cruise but it was good. Where else do you suggest checking? Clockspring?

2nd one isnt really a problem but more like a WTF. I pulled into work this morning and after cooling down i go to flip the key off and the truck kept running for a good 1-2 seconds past when i turned the to off. Any thing i should look at what could have caused this

Local Jackass member Pat

Battle cry of every 6.0 owner out there
Quote:
Originally Posted by access_max View Post
With the issues fixed a 6.0 can run circles around a 7.3.
2000 F-350 7.3L ZF6
Standard 7.3 mods
SCT tuned
8" Fabtech lift 13" total
5:13 Gears
46" Goodyear MVTs Military takeoffs
Bushwacker Cut-Out Fender Flares
Ranch Hand front and rear bumper
On-board air W/Semi horns

1995 F-350 7.3L E4OD DRW
Standard 7.3 mods
PHP Hydra W/Tony Wildman tunes
160/0 Injectors
T-500 HPOP
E-fuel Conversion
West Coast mirrors
Rammstein1224 is offline  
post #2 of 11 Old 10-14-2013, 08:55 AM
Member
 
Join Date: Aug 2013
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
For the cruise, check the relay on the firewall, right in front of the steering wheel. Mine goes out once in a while. The other...?????
Good luck.

1996 F-350 Crew, Long Bed
injun46 is offline  
post #3 of 11 Old 10-14-2013, 08:57 AM Thread Starter
Chapter Director

 
Rammstein1224's Avatar
 
Join Date: Aug 2012
Location: Davenport, IA
Posts: 2,931
Thanks: 4
Thanked 45 Times in 37 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Quote:
Originally Posted by injun46 View Post
For the cruise, check the relay on the firewall, right in front of the steering wheel. Mine goes out once in a while. The other...?????
Good luck.
Well would that cause the horn to not work either?

Local Jackass member Pat

Battle cry of every 6.0 owner out there
Quote:
Originally Posted by access_max View Post
With the issues fixed a 6.0 can run circles around a 7.3.
2000 F-350 7.3L ZF6
Standard 7.3 mods
SCT tuned
8" Fabtech lift 13" total
5:13 Gears
46" Goodyear MVTs Military takeoffs
Bushwacker Cut-Out Fender Flares
Ranch Hand front and rear bumper
On-board air W/Semi horns

1995 F-350 7.3L E4OD DRW
Standard 7.3 mods
PHP Hydra W/Tony Wildman tunes
160/0 Injectors
T-500 HPOP
E-fuel Conversion
West Coast mirrors
Rammstein1224 is offline  
post #4 of 11 Old 10-14-2013, 09:05 AM
Premium Member
 
john galt's Avatar
 
Join Date: Apr 2013
Posts: 4,528
Thanks: 167
Thanked 287 Times in 281 Posts
Mentioned: 31 Post(s)
Quoted: 638 Post(s)
Feedback Score: 0 reviews
not sure I have the same problem (aside from the running after shutdown) and I assumed it was my clockspring as they are kinda known to go out... but the ignitions thing? I have NO idea?
hopefully you will get someone on here with more knowledge than i have amassed thus far.

early 04 f350 6.0 cclb lariat sr
Bulletproof oil &egr, elc, sct x3, edge CTS, afe intake, blue spring, t-500, MTW stage 2, Vivians looney, 305 x55x20 bfg at ko's, 4 inch cat back, 4"BDS fox shocks and steering stabilizer, tri pilar gauge set, sinister coolant filter(this is the ONLY pos sinister product that will ever be on my truck), riff raff boots, new headliner, 7 inch touch screen w/back up, new carpet, near whole new interior,


FederalOwnershipRespectfullyDeclined

john galt is online now  
post #5 of 11 Old 10-14-2013, 09:07 AM Thread Starter
Chapter Director

 
Rammstein1224's Avatar
 
Join Date: Aug 2012
Location: Davenport, IA
Posts: 2,931
Thanks: 4
Thanked 45 Times in 37 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Quote:
Originally Posted by john galt View Post
not sure I have the same problem (aside from the running after shutdown) and I assumed it was my clockspring as they are kinda known to go out... but the ignitions thing? I have NO idea?
hopefully you will get someone on here with more knowledge than i have amassed thus far.
Well the shut down thing i think maybe was a glitch in the pcm or something, as long as it doesnt happen anymore or worse i cant get it to shut off.

Local Jackass member Pat

Battle cry of every 6.0 owner out there
Quote:
Originally Posted by access_max View Post
With the issues fixed a 6.0 can run circles around a 7.3.
2000 F-350 7.3L ZF6
Standard 7.3 mods
SCT tuned
8" Fabtech lift 13" total
5:13 Gears
46" Goodyear MVTs Military takeoffs
Bushwacker Cut-Out Fender Flares
Ranch Hand front and rear bumper
On-board air W/Semi horns

1995 F-350 7.3L E4OD DRW
Standard 7.3 mods
PHP Hydra W/Tony Wildman tunes
160/0 Injectors
T-500 HPOP
E-fuel Conversion
West Coast mirrors
Rammstein1224 is offline  
post #6 of 11 Old 10-14-2013, 10:50 AM
Compression Ignition Addict
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 3,876
Thanks: 4
Thanked 129 Times in 125 Posts
Mentioned: 0 Post(s)
Quoted: 32 Post(s)
Feedback Score: 0 reviews
Common thing between the horn and cruise is the steering wheel, so yeah, that's where I'd start looking (clockspring, ground). Haven't checked the EVTM in a while, but I've never heard of any relay on the firewall, related to the cruise or anything else for that matter. Relays are all in the underhood power distribution box, except for the starter and glow plug relays.

Last edited by madpogue; 10-14-2013 at 11:10 AM.
madpogue is offline  
post #7 of 11 Old 10-14-2013, 11:01 AM Thread Starter
Chapter Director

 
Rammstein1224's Avatar
 
Join Date: Aug 2012
Location: Davenport, IA
Posts: 2,931
Thanks: 4
Thanked 45 Times in 37 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Quote:
Originally Posted by madpogue View Post
Common thing between the horn and cruise is the steering wheel, so yeah, that's where I'd start looking. Haven't checked the EVTM in a while, but I've never heard of any relay on the firewall, related to the cruise or anything else for that matter. Relays are all in the underhood power distribution box, except for the starter and glow plug relays.
I didnt think so either, ill go through and look at all the fuses tonight other than the cruise one. It was late so not much troubleshooting time. Ill see if im even getting power to the steering wheel

Local Jackass member Pat

Battle cry of every 6.0 owner out there
Quote:
Originally Posted by access_max View Post
With the issues fixed a 6.0 can run circles around a 7.3.
2000 F-350 7.3L ZF6
Standard 7.3 mods
SCT tuned
8" Fabtech lift 13" total
5:13 Gears
46" Goodyear MVTs Military takeoffs
Bushwacker Cut-Out Fender Flares
Ranch Hand front and rear bumper
On-board air W/Semi horns

1995 F-350 7.3L E4OD DRW
Standard 7.3 mods
PHP Hydra W/Tony Wildman tunes
160/0 Injectors
T-500 HPOP
E-fuel Conversion
West Coast mirrors
Rammstein1224 is offline  
post #8 of 11 Old 10-14-2013, 11:10 AM
Member
 
Join Date: Aug 2013
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Maybe my relay on the firewall was put in by the previous owner, but it works the cruise.
The horn relay is in the under hood fuse box, center relay spot. Here's a link that shows it.
1996 Ford F350 Super Duty XLT Engine Compartment Fuse Box Diagram » Auto Fuse Box Diagram
Hope this helps. I'm new at working on powerstrokes, don't know a lot.
My 96 wouldn't start this morning, check engine light on and all. Switched the PCM relay with the horn relay and it started, and horn worked too. Go figure. Good luck.

1996 F-350 Crew, Long Bed
injun46 is offline  
post #9 of 11 Old 10-16-2013, 10:36 AM Thread Starter
Chapter Director

 
Rammstein1224's Avatar
 
Join Date: Aug 2012
Location: Davenport, IA
Posts: 2,931
Thanks: 4
Thanked 45 Times in 37 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 5 reviews
Cruise and horn not working ended up being a relay in the distribution box, as for not shutting off it hasnt done it since so maybe a slightly had the ignition on or a glitch or something oh well

Local Jackass member Pat

Battle cry of every 6.0 owner out there
Quote:
Originally Posted by access_max View Post
With the issues fixed a 6.0 can run circles around a 7.3.
2000 F-350 7.3L ZF6
Standard 7.3 mods
SCT tuned
8" Fabtech lift 13" total
5:13 Gears
46" Goodyear MVTs Military takeoffs
Bushwacker Cut-Out Fender Flares
Ranch Hand front and rear bumper
On-board air W/Semi horns

1995 F-350 7.3L E4OD DRW
Standard 7.3 mods
PHP Hydra W/Tony Wildman tunes
160/0 Injectors
T-500 HPOP
E-fuel Conversion
West Coast mirrors
Rammstein1224 is offline  
post #10 of 11 Old 10-17-2013, 09:06 AM
Member
 
Join Date: Aug 2013
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Figured out the relay on my firewall. Somehow it was wired into the cruise, and the relay was for the Pacbrake that has never worked right. When that relay went bad the cruise stopped working.
Sorry for the mis-lead, it wasn't intended.
Glad ya got 'er fixed.
Signed: Still learning in Florida.

1996 F-350 Crew, Long Bed
injun46 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome