Oil Pressure - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-01-2008, 05:51 AM
haters gonna hate 24/7.
 

Join Date: Oct 2007
Location: Deer Park, Tx
Posts: 3,804
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Oil Pressure

I was driving to work this morning and i noticed my oil pressure gauge was pegged at H. I stopped and turned the truck off and restarted the truck and it was still pegged at H. Then right before i got to work, the gauge went back to reading normal.... Anybody else have this problem???

I appreciate the help ya'll
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-18-2008, 09:16 AM
Compression Ignition Addict
 

Join Date: Mar 2008
Posts: 642
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to kx592
sounds like your gauge may be giving you a false read if its spiratic like that? Anyone else got an idea?
Reply With Quote Quick reply to this message
  #3  
Old 05-18-2008, 09:19 AM
Nuckin' Futz


 

Join Date: Jul 2006
Posts: 700
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
id find out if your oil pump was acting up and the pressure relief got stuck closed for a bit there...id do that promptly before you blow out all your seals if it is that...then if it isn't you can look at your gauge as being the problem.
Reply With Quote Quick reply to this message
  #4  
Old 05-18-2008, 09:34 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 2,005
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to somebodyelse5
Does you fuel guage do that too? mine has a mind of its own, and ive heard its common.....
Reply With Quote Quick reply to this message
  #5  
Old 05-18-2008, 10:08 AM
Compression Ignition Addict
 

Join Date: Mar 2008
Posts: 642
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to kx592
Well the fuel one is casued by dirt in the senser when you only fill one tank...there different problems
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:44 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors