'95 F250 Shaky Speedo & ABS light - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2013, 07:00 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Location: Temecula, CA
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question '95 F250 Shaky Speedo & ABS light

It was very bad. Speedo wouldn't register under 30 and bounced around like a big dog while driving.

I pulled the diff cover, Oil was burnt and factory, of course. However, No metal shavings in oil. the tone ring was not missing teeth.

I put the cover back on, refilled, replaced the VSS. Used some electrical safe cleaner on connector.

This did offer quite a bit of improvement. It registers at low speeds and the swing is much less, but still there & the ABS light is still on.

Where to go from here? Replace the Harness?
Any help would be awesome.

- Joe
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-25-2013, 08:33 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Location: Temecula, CA
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update!

ABS light is OFF! I disconnected ground to reset ECM. Going to put 120+ miles on it in the morning. Will post another update.
- Joe
Reply With Quote Quick reply to this message
  #3  
Old 05-26-2013, 06:02 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Location: Temecula, CA
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
114 Miles, ABS light is still off. Speedo still shaky.
Reply With Quote Quick reply to this message
  #4  
Old 05-27-2013, 12:01 AM
Serving Our Country!
 

Join Date: Aug 2007
Location: Manor, TX
Posts: 2,879
Thanks: 0
Thanked 18 Times in 17 Posts
Feedback Score: 2 reviews
There are only a few components in that loop. The tone ring could have teeth that are bent rather than missing. The VSS could be bad. The wire or connectors could be bad. PSOM could be bad or the RABS could be bad.

If you have access to a oscilloscope, you can jack the rear end up and connect to the VSS to check the signal. Otherwise you are just guessing. The VSS is only about $30 so I would start with that.
Reply With Quote Quick reply to this message
  #5  
Old 05-27-2013, 04:35 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Location: Temecula, CA
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question

Quote:
Originally Posted by JSchuricht View Post
There are only a few components in that loop. The tone ring could have teeth that are bent rather than missing. The VSS could be bad. The wire or connectors could be bad. PSOM could be bad or the RABS could be bad.

If you have access to a oscilloscope, you can jack the rear end up and connect to the VSS to check the signal. Otherwise you are just guessing. The VSS is only about $30 so I would start with that.
Did the new VSS (18$, Ato Zn), Changed the harness also($11), tone Ring looked good.

165 miles since ABS light shut off. Has not come back on.

I am going to take it to electrical specialist friend of mine to look for short or pinch in line.
Reply With Quote Quick reply to this message
  #6  
Old 05-28-2014, 10:35 PM
Powerstroke.org Rookie
 

Join Date: May 2014
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am experiencing the same problem. Did you ever find the solution to the problem?
Reply With Quote Quick reply to this message
  #7  
Old 06-25-2014, 06:34 PM
Powerstroke.org Rookie
 

Join Date: Apr 2007
Location: Victoria, Texas
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to nick40 Send a message via Yahoo to nick40
I have the same problem but mine only oscillates between 45 and 55 mph... Any updates?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors