Voltage Problem, reverse problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-01-2013, 06:13 AM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Voltage Problem, reverse problem

Hi everyone! great forums here, i read posts on a daily basis!

On with the situation. I have a 1998 Ford E 350 7.3 Powerstroke ambulance. I purchased the vehicle this week after it was sitting, unstarted for 1.5 years minimum. Truck starts up and got new batteries in. The guy i bought it from said it needs a new alternator. When started, it shows 16 volts and has a battery light on the dash. I took the alternator out and had it tested at autozone who said it tests fine. I cant figure it out. I inspected the battery cables as much as i can and everything seems in order. I tried grounding the alternator to metal and negative terminal hoping it would be a bad ground, no luck. I cant find an external voltage regulator, but i;m not sure where to look. Also, the truck stalls in reverse unless you give it steady throttle, unsure if its related.

Thanks in advance for any help!

David.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:58 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors