'95 7.3 Powerstroke will not start hot. IPR valve? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-01-2007, 09:06 AM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2007
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
'95 7.3 Powerstroke will not start hot. IPR valve?

My 7.3 powerstroke will not start hot... in fact my father was driving when he put it in a lower gear to slow down and it quit running. I gave it a shot of ether and it started and runs fine. (Replaced filter).

Once the engin is warm, it will not start without ether.

The local dealer says I need a new IPR valve and wants to charge me $998.00.

In reading other post, some people say an O-ring sometimes burst.

Do you think I need an IPR valve or just an O-ring?

I think I can get an IPR for about $400.00. Can I put this baby in myself and save the labor? I don't even know where this IPR thing is, but I am somewhat mechanical.


Roger B.

Last edited by excelsiorfarm; 11-01-2007 at 05:27 PM. Reason: Clarification
excelsiorfarm is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome