NEED HELP WITH A FORD - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-24-2012, 11:05 AM Thread Starter Rookie
Join Date: Nov 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

So I have a 1997 Ford F350 been workin on for bout 2 weeks now. Needed head gasket and new injector cups. Got them in and fixed. Run the truck for about 12 miles and died. So towed it back to the house with my other truck and started the figuring out. Here is what I have done with it. First off pulled codes most common codes are 1280, 603, and 344. So replaced the cam sensor. I tested the HPOP pressure on crank and only got about 237PSI so replaced the HPOP then it pegged out my little 500PSI guage on the crank. Tested fuel pressure got none put a new fuel pump on it the mechanical pump. Tested the UVC harnesses they tested out fine. Took the truck to my buddy down at ford he did a buzz test IDM and all 8 injectors test out fine. Replaced the fuel filter on a hunch and still nothing. Yesterday got it to run on ether to get all the air out of the High Pressure Oil sys and the fuel rail. Now the truck will run at half throttle for about 30 seconds the cel comes on and truck kills out will not start on its own, almost the same at WOT except it will only run for 8-10 seconds then cel comes on and kills out. Pulled codes again and the only codes I am getting are 344 and 1280. I am at a loss. I am a cummins man I know just about everything to know about them I have 2 fords and now it is pushing what I know.
here is the cam pn originally from the truck itself #1876735C91
OH and I took apart the IPR cleaned it and put it back in.
starsandjojo11 is offline  
Sponsored Links
post #2 of 2 Old 11-24-2012, 02:36 PM
Compression Ignition Addict
Chop's Avatar
Join Date: Feb 2010
Location: Glen Allen Va
Posts: 583
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 4
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Don't know much about the codes but i suggest looking at the fuel bowl heater element .These are prone to shift and short out causing power loss to the IDM .It will blow # 22 fuse ,the lack of a wait to start ( wts ) light is another symptom .Most just disconnect heater .

1996 F250 PSD Crewcab,auto,D 60 swap,3" dp, DIY air 4X4 Centurion
Chop is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome