Glow plug test results? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-22-2012, 08:26 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Glow plug test results?

Some of the glow plugs read 0.00 ohms and some of them 0.01 so I would think they need replaceing? when I put a test light on them the light is on. The GPR is getting 12.5 v and when the key is on the glow plug side of relay is 10.5 v -is that voltage drop ie: 2 v? ---not sure if it good or bad. Thanks for your help
pinebeatle is offline  
post #2 of 3 Old 10-23-2012, 05:58 AM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 80 Times in 78 Posts
Feedback Score: 0 reviews
Sounds like you need new plugs, assuming your meter is accurate. Is the battery side of the relay have the same 12.5V when the key is on and relay activated? If so, your relay is bad (I like to place the meter leads on the relay's large terminals ... one lead on the battery side and one on the glowplug side ... that measures the drop directly). Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #3 of 3 Old 10-23-2012, 07:48 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Patrick Feeley View Post
Sounds like you need new plugs, assuming your meter is accurate. Is the battery side of the relay have the same 12.5V when the key is on and relay activated? If so, your relay is bad (I like to place the meter leads on the relay's large terminals ... one lead on the battery side and one on the glowplug side ... that measures the drop directly). Cheers!
Thanks For the info--Cheers
pinebeatle is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome