Battery Light - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-07-2012, 02:54 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Charlotte, NC
Posts: 294
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Battery Light

I started my truck today and the battery light came on. Let it run 15 minutes then shut it off and restarted it about 5 times without any problems. What all should I be looking for?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-07-2012, 03:09 PM
Member
 

Join Date: Feb 2010
Posts: 49
Thanks: 8
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
F250 '95 Powerstroke Battery Light Stays On

Quote:
Originally Posted by tucker0104 View Post
I started my truck today and the battery light came on. Let it run 15 minutes then shut it off and restarted it about 5 times without any problems. What all should I be looking for?
I have the same problem & 2nd this question needing to be answered, mine has almost alway gone on for no apparent reason, AND the ABS light although there's break fluid, etc.

Any info is good info on these matters.
Reply With Quote Quick reply to this message
  #3  
Old 08-07-2012, 03:57 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Charlotte, NC
Posts: 294
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am fine if it is just the battery light for no reason. I just don't want to be driving down the road and all of a sudden I break down.
Reply With Quote Quick reply to this message
  #4  
Old 08-07-2012, 04:07 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Charlotte, NC
Posts: 294
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It seems like the batteries are staying charged which means the alternator is working. Batteries are only about 6 months old. Could grounding straps cause a battery light?
Reply With Quote Quick reply to this message
  #5  
Old 08-08-2012, 02:50 PM
Hee Hee, he's doing it...
 

Join Date: Oct 2011
Location: Pasadena, CA
Posts: 5,502
Thanks: 44
Thanked 86 Times in 81 Posts
Feedback Score: 0 reviews
Time for an Alt. When the Batt. light is on try tapping the Alt. housing. Might be a bad ground in/on the ALt. Food for thought:

Reply With Quote Quick reply to this message
  #6  
Old 08-08-2012, 04:00 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Charlotte, NC
Posts: 294
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
But there seems to be power. No way the alternator is bad but the batteries are staying at 14v when running.
Reply With Quote Quick reply to this message
  #7  
Old 08-08-2012, 04:07 PM
Hee Hee, he's doing it...
 

Join Date: Oct 2011
Location: Pasadena, CA
Posts: 5,502
Thanks: 44
Thanked 86 Times in 81 Posts
Feedback Score: 0 reviews
Tap on the housing to see if it's a bad ground issue in the alternator. Otherwise inspect the LG/R wire from the alternator back to the light.
Reply With Quote Quick reply to this message
  #8  
Old 08-09-2012, 04:30 AM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Charlotte, NC
Posts: 294
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I will check it today. Thanks for the help. Where can the wire be found on the alternator?
Reply With Quote Quick reply to this message
  #9  
Old 08-09-2012, 04:32 AM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: Gainesville, FL
Posts: 1,185
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Skype™ to bwmtnbiker
My cousins truck did this, pulled the alt off and took it to get tested. Tested bad and we replaced it. The light went away after that.
Reply With Quote Quick reply to this message
  #10  
Old 08-09-2012, 04:49 AM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Charlotte, NC
Posts: 294
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Any recommendations on new alternator brands?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:08 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors