EBPV Issues/ Thermostat Issues - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-19-2012, 03:26 AM Thread Starter
Member
 
19Dscout's Avatar
 
Join Date: Oct 2009
Location: Olympia, WA
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to 19Dscout Send a message via Skype™ to 19Dscout
EBPV Issues/ Thermostat Issues

Well my truck finnaly turned 100k, and it has been having a few issues. 1) The temp gauge never get's warmed up, it sits about the N or just under, reguardless of how long you drive it, but has plenty of hot air coming through the vents. Second almost everytime I start it now, I am assuming the EBPV is sticking, it sounds like a exhust break constantly, except higher RPM, but once you let off, it comes back, sometimes it will do this for a hour, and has no power, but other times it fires right up and is great, I am kinda thinking the thermostat is stuck open, and the EBPV is staying shut trying to get it warmed up, and info would be great.

97 f-350
58k
5 speed, 3.55s
3'' dp, 4in straight piped,
fpr shim,
19Dscout is offline  
post #2 of 4 Old 06-19-2012, 11:44 AM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,226
Thanks: 0
Thanked 86 Times in 84 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
Could be a stuck-open T-stat as far as the coolant tempgoes. For the EBPV issue, you can try cleaning out the tube that runs from the passenger side exhaust manifold under the alternator and up to the EBP sensor near the HPOP Reservoir. It snakes out from under the alternator without any difficulty. Once its out, use some carb cleaner and some wire rope chucked in a variable-speed drill (like a plumbing snake) to unclog the soot. Also make sure the little pice left on the EBP sensor side is clean too. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #3 of 4 Old 06-19-2012, 04:00 PM
Compression Ignition Addict
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by 19Dscout View Post
Well my truck finnaly turned 100k, and it has been having a few issues. 1) The temp gauge never get's warmed up, it sits about the N or just under, reguardless of how long you drive it, but has plenty of hot air coming through the vents. Second almost everytime I start it now, I am assuming the EBPV is sticking, it sounds like a exhust break constantly, except higher RPM, but once you let off, it comes back, sometimes it will do this for a hour, and has no power, but other times it fires right up and is great, I am kinda thinking the thermostat is stuck open, and the EBPV is staying shut trying to get it warmed up, and info would be great.
Sound like your on the right track to me, my temp was way low too. I changed the thermostat, it helped a little, now I think my fan clutch is not disengaging all the way. My 96 has 309k. :thumbup:

Sent from my SCH-I500

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

SEE MY OIL COOLER REPLACEMENT AND EGR DELETE - http://www.powerstroke.org/forum/gen...tml?highlight=
southend is offline  
post #4 of 4 Old 06-19-2012, 09:10 PM Thread Starter
Member
 
19Dscout's Avatar
 
Join Date: Oct 2009
Location: Olympia, WA
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to 19Dscout Send a message via Skype™ to 19Dscout
I will try cleaning out the line before I delete my EBPV, hope it works, and I am going to put a new thermostat in, try to bring up the temp a bit, I want to do E-fan on it, once I get home, thanks guys, any more thoughts send them my way,

97 f-350
58k
5 speed, 3.55s
3'' dp, 4in straight piped,
fpr shim,
19Dscout is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome