Lost pulling power? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-30-2012, 05:10 AM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Burkeville,TEXAS
Posts: 240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Lost pulling power?

Hey guys last night I hooked up to my camper(38'), and could feel a big loss in pulling power, and my egts stayed over 1000* the whole time, at 60mph, 2300RPMs and only made 11psi boost, thing felt like my old IDI. Any ideas, TRANS, or Engine problem? Will try to take a look at it after work today. And my TRANS temp climbed to 200* which isn't normal either?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-08-2012, 06:47 AM
Banned
 

Join Date: Sep 2008
Location: Fort Bragg, NC/Buff, NY/Midlothian, VA
Posts: 5,630
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I would only post in the General or the Performance section... not many people check this part of the forum.
Reply With Quote Quick reply to this message
  #3  
Old 05-10-2012, 05:36 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Lewisburg, Pa
Posts: 1,186
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
trans temp high because you weren't in overdrive that time? Check your orange boots for a boost leak.
Reply With Quote Quick reply to this message
  #4  
Old 05-10-2012, 07:02 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Burkeville,TEXAS
Posts: 240
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'll pull the boots, and see if I can find any small splits, and no I wasn't in OD, but I don't rember the temp climbing that high before. I only pulled about 15 miles.
Reply With Quote Quick reply to this message
  #5  
Old 05-11-2012, 10:27 AM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Lewisburg, Pa
Posts: 1,186
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Mine climbs fast pulling hard with a lot of power and od off


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #6  
Old 05-11-2012, 10:31 AM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: East Canaan, CT
Posts: 396
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ebpv isnt stuck right?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors