abs light, cruise control, no brake lights - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-26-2007, 11:31 AM
Member
 

Join Date: Sep 2007
Location: New River
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
abs light, cruise control, no brake lights

I have a 96 7.3. My abs light is on, brake lights not working (blinkers work), cruise not working, and shifts wierd at cruising speed. When I take off from a stop it goes through the gears normal but when I get up to speed the wierd shifting starts. When I increase speed the engine slows down about 200 rpms initially then when I hold the pedal steady rpms jump up again. This all happened at the same time so Im assuming their related. The transmission is not down shiffting it is something else. The only mods I have ar 4" exhaust, edge programmer and egt gauge.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-26-2007, 11:37 AM
International Threat
 

Join Date: May 2006
Location: Elkton, MD
Posts: 13,087
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 1 reviews
Not real sure but bumpity bumP!
Reply With Quote Quick reply to this message
  #3  
Old 09-26-2007, 11:18 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check fuse #13 under the dash
Reply With Quote Quick reply to this message
  #4  
Old 09-27-2007, 01:26 AM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Northern Calif
Posts: 254
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check speed sencer on top rear diff
Reply With Quote Quick reply to this message
  #5  
Old 09-27-2007, 03:05 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
i would guess rear speed sensor , cheap fix , lounted on top of the rear end
Reply With Quote Quick reply to this message
  #6  
Old 09-27-2007, 10:14 AM
Member
 

Join Date: Sep 2007
Location: New River
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Checked fuse #13 its good. Disconnected neg. batt. cables, replaced speed sensor on rear diff., reconnected batteries, problem is still there. Thanks for the ideas. Any other options?
Reply With Quote Quick reply to this message
  #7  
Old 09-27-2007, 10:17 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by tinlizzy View Post
Checked fuse #13 its good. Disconnected neg. batt. cables, replaced speed sensor on rear diff., reconnected batteries, problem is still there. Thanks for the ideas. Any other options?
dont spend any more money on guessing, lets get the abs codes pulled and go from there
Reply With Quote Quick reply to this message
  #8  
Old 09-27-2007, 10:26 AM
Member
 

Join Date: Sep 2007
Location: New River
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I brought it to blackwell automotive in phx and they said the abs light wasnt on for them and it didnt shift wierd. I'll try another shop.
Reply With Quote Quick reply to this message
  #9  
Old 09-27-2007, 10:46 AM
Compression Ignition Addict
 

Join Date: Jul 2007
Posts: 304
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Smile az

look on the arizona power group site have a bunch of local vendors can help.Arizona PowerStroke Group (APG)

Last edited by jostaman; 09-27-2007 at 10:47 AM. Reason: wrong address
Reply With Quote Quick reply to this message
  #10  
Old 01-26-2008, 07:57 PM
Member
 

Join Date: Sep 2007
Location: New River
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
A little late on the follow up. I changed the multi function switch (blinker, hazard wiper, etc.) fixed the problem. $150 from the dealer.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:06 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors