abs light, cruise control, no brake lights - Ford Powerstroke Diesel Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 Old 09-26-2007, 11:31 AM Thread Starter
Member
 
Join Date: Sep 2007
Location: New River
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
abs light, cruise control, no brake lights

I have a 96 7.3. My abs light is on, brake lights not working (blinkers work), cruise not working, and shifts wierd at cruising speed. When I take off from a stop it goes through the gears normal but when I get up to speed the wierd shifting starts. When I increase speed the engine slows down about 200 rpms initially then when I hold the pedal steady rpms jump up again. This all happened at the same time so Im assuming their related. The transmission is not down shiffting it is something else. The only mods I have ar 4" exhaust, edge programmer and egt gauge.
tinlizzy is offline  
post #2 of 15 Old 09-26-2007, 11:37 AM
International Threat
 
Marty's Avatar
 
Join Date: May 2006
Location: Elkton, MD
Posts: 13,088
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 9 Times in 5 Posts
Feedback Score: 1 reviews
Not real sure but bumpity bumP!

2001 F250
11.62 @ 115.79
Owner of Marty's Diesel
Elkton, Maryland
Marty is offline  
post #3 of 15 Old 09-26-2007, 11:18 PM
Powerstroke.org Rookie
 
Join Date: Sep 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check fuse #13 under the dash
bur257 is offline  
post #4 of 15 Old 09-27-2007, 01:26 AM
Compression Ignition Addict
 
Join Date: Feb 2007
Location: Northern Calif
Posts: 254
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check speed sencer on top rear diff
ono_55 is offline  
post #5 of 15 Old 09-27-2007, 03:05 AM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,304
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
i would guess rear speed sensor , cheap fix , lounted on top of the rear end

SCUFFY828@POWERSTROKE.ORG
ITS STOCK
SCUFFY828 is offline  
post #6 of 15 Old 09-27-2007, 10:14 AM Thread Starter
Member
 
Join Date: Sep 2007
Location: New River
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Checked fuse #13 its good. Disconnected neg. batt. cables, replaced speed sensor on rear diff., reconnected batteries, problem is still there. Thanks for the ideas. Any other options?
tinlizzy is offline  
post #7 of 15 Old 09-27-2007, 10:17 AM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,304
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by tinlizzy View Post
Checked fuse #13 its good. Disconnected neg. batt. cables, replaced speed sensor on rear diff., reconnected batteries, problem is still there. Thanks for the ideas. Any other options?
dont spend any more money on guessing, lets get the abs codes pulled and go from there

SCUFFY828@POWERSTROKE.ORG
ITS STOCK
SCUFFY828 is offline  
post #8 of 15 Old 09-27-2007, 10:26 AM Thread Starter
Member
 
Join Date: Sep 2007
Location: New River
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I brought it to blackwell automotive in phx and they said the abs light wasnt on for them and it didnt shift wierd. I'll try another shop.
tinlizzy is offline  
post #9 of 15 Old 09-27-2007, 10:46 AM
Compression Ignition Addict
 
jostaman's Avatar
 
Join Date: Jul 2007
Posts: 304
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Smile az

look on the arizona power group site have a bunch of local vendors can help.Arizona PowerStroke Group (APG)

Last edited by jostaman; 09-27-2007 at 10:47 AM. Reason: wrong address
jostaman is offline  
post #10 of 15 Old 01-26-2008, 07:57 PM Thread Starter
Member
 
Join Date: Sep 2007
Location: New River
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
A little late on the follow up. I changed the multi function switch (blinker, hazard wiper, etc.) fixed the problem. $150 from the dealer.
tinlizzy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome