SES light - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-11-2012, 07:07 PM
Member
 

Join Date: Mar 2010
Location: Eureka
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
SES light

Hey guys was wondering where exactly the ses light on these trucks are. Mine hasnt worked since I got it. Trying to figure out if it's a bulb or? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-16-2012, 03:22 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Madison, WI
Posts: 3,145
Thanks: 3
Thanked 75 Times in 72 Posts
Feedback Score: 0 reviews
Right side of the cluster. And it says "Check Engine", rather than "Service Engine Soon". Look again; the bulb test is crazy short, like 1/10 second. Keep your eye peeled on that side of the cluster as you turn the key to RUN. Blink, and you'll miss it......
Reply With Quote Quick reply to this message
  #3  
Old 03-20-2012, 12:00 PM
Member
 

Join Date: Mar 2010
Location: Eureka
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks. Mine is definitely not working. A picture would be great so I can try to replace the bulb.
Reply With Quote Quick reply to this message
  #4  
Old 03-20-2012, 10:14 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Madison, WI
Posts: 3,145
Thanks: 3
Thanked 75 Times in 72 Posts
Feedback Score: 0 reviews
It's between the seat belt light and the ABS light, in that rightmost column of lights, to the right of the tach. Well I couldn't get a still pic, because it flashes SO fast. I got to play with the slow-mo movie feature on my camera and got a short video.
Did you see it flash? That's actually 1/4 speed; that gives you and idea how short it flashes.

I was trying to figure out what sensor to unplug, to force the light on, but....
Reply With Quote Quick reply to this message
  #5  
Old 03-20-2012, 11:29 PM
Member
 

Join Date: Mar 2010
Location: Eureka
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thank you for the video. Mine is definitely not working and neither is the seatbelt light so I'll have to dig around a bit. Might be a wiring issue going on. Appreciate the help, let you know what I find when I get a chance to work on it in between the 60 swap and all my other projects.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:22 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors