runs fine then boggs out - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-03-2012, 10:54 AM Thread Starter Rookie
Join Date: Mar 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
runs fine then boggs out

i have a 1996 7.3 that started having trouble today. i was pulling an empty stock trailer down the highway and started up this hill and then it just started to bogg out at the top of the hill and just ran herself down. i had to pull over and let it sit for a bit, changed the fuel filter and that didnt help. i plugged it into two separate scanners and nothing came up on either of them. not real sure whats going on. need help
WhItE96StRoKeR7.3 is offline  
post #2 of 2 Old 03-07-2012, 04:53 PM Rookie
Join Date: Jan 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hey Whit,
Disconnect your maf sensor and take it for a ride and see if everything is back to normal.
You will get a CEL but not to worry it will go off once the maf is plugged back in.
If what I just suggested works, then get a new sensor.

Let me know what happens,
Later Gator
tnilc999 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome