'95 F350 PSD Air Conditioning - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-29-2006, 06:19 PM
Powerstroke.org Rookie
 

Join Date: Jun 2006
Location: Amarillo, Texas
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
'95 F350 PSD Air Conditioning

Hello All,

I'm having an issue with my trucks A/C, specifically with the blower output. The air is nice and cold, it just doesn't blow out of the vents very hard. Also when you move the swith from Normal A/C to MAX A/C the fan doesn't blow any harder in MAX - even with the Fan switch turned up all the way. Is there a booster fan or a relay that could be out? Any help would be appreciated! Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-29-2006, 06:57 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
there are two actual controll componants. the first is the resistor that is what the switch uses to controll speed, and hte other is the switch. the resistor generally fails and the fan will ONLY work on high. your issue sounds like a switch failure, but i cant say that for sure without proper testing....
Reply With Quote Quick reply to this message
  #3  
Old 06-29-2006, 07:05 PM
Powerstroke.org Rookie
 

Join Date: Jun 2006
Location: Amarillo, Texas
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So there is only 1 Fan, NO booster? Could I jumper 12 volts directly to the fan motor and see if it blows harder? Again, thanks for your help - on both threads!
Reply With Quote Quick reply to this message
  #4  
Old 06-29-2006, 07:07 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
PM and i will give you my number, i will help with both problems. Yes, if you jumper 12v to the fan you should get high speed operation, but that still will not tell you if the relay or switch is the problem....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:48 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors