Glow Plug light not coming on - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-27-2012, 07:24 AM Thread Starter
Member
 
twodot's Avatar
 
Join Date: Sep 2009
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Glow Plug light not coming on

'97 F350 glow plug light is not coming on. tough to turn over. Fuses okay. Cleaning battery terminals etc. Outdoor temps in mid 30s.
Any thoughts?
twodot is offline  
post #2 of 4 Old 01-27-2012, 11:23 AM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,225
Thanks: 0
Thanked 80 Times in 78 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
The glow plug light meaning the Wait-to-Start light? Check fuses #9 and #22 in the underhood fusebox with a meter to make sure it is good. Make sure the PCM relay is good. Just a note: The WTS light is controlled by the PCM and really has nothing to do with how long the glowplugs are on (or if they are working). Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #3 of 4 Old 01-27-2012, 03:31 PM Thread Starter
Member
 
twodot's Avatar
 
Join Date: Sep 2009
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
.Patrick, thank you! My wife made the original post with my question about the glow plug/ wait to start light. She forgot to mention that the truck would not start.
So,
I took batteries in and had them load tested, they were good.
Then I came home and took the starter off and had it bench tested.
Bad starter.
Replaced starter.
Now truck starts and runs well, again but the wait to start light still does not work.
I had checked the 30 amp fuse (I think number 22) and it was good. I did not know that there was another to look for. I will run out and check that one also. Got as feeling that it will be blown.

thanks again, twodot

edit, What the heck is my PCM relay

Last edited by twodot; 01-27-2012 at 03:37 PM.
twodot is offline  
post #4 of 4 Old 01-27-2012, 06:38 PM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,225
Thanks: 0
Thanked 80 Times in 78 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
If the truck is starting and running the relay and fuses are good (the relay is one of the little cubes in the underhood fusebox). Your WTS lightbulb may just be bad. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome