help! i have a few instrument cluster problems. - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-21-2007, 11:01 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2007
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
help! i have a few instrument cluster problems.

2 weeks ago, i bought a '97 F-350 PSD with what looks like to be a bad cluster. the rpm's work along with the fuel gauge and the battery gauge. that's it. the cluster wont read the speedometer, the oil pressure or the coolant temp. what could be my problem here? does my truck have a bad cluster or do i have bad sensors somewhere? please help somebody?
nu2diesels is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-21-2007, 11:45 PM
PIPE HITTER
 
gcop's Avatar
 
Join Date: Mar 2006
Location: Republic of Texas
Posts: 1,472
Thanks: 0
Thanked 2 Times in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My guess would be the cluster. Seems unlikely that you would have bad speedo, oil and temp sensore all at the same time. You may can find a used junkyard cluster reasonable enough.

"Life is hard, it's even harder when you are stupid"
gcop is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome